Author Topic: Cannot access tty1  (Read 13511 times)

Neon_Riots

  • Posts: 30
    • View Profile
Re: Cannot access tty1
« Reply #15 on: March 17, 2013, 04:13:29 PM »
After reboot I'm greeted with a flashing cursor at the top left but nothing else.

Hitting enter or ctrl alt f1 didn't have any effect.

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: Cannot access tty1
« Reply #16 on: March 17, 2013, 06:56:42 PM »
And does the grub screen come up?
Don't Be A Dick!

Neon_Riots

  • Posts: 30
    • View Profile
Re: Cannot access tty1
« Reply #17 on: March 17, 2013, 07:08:54 PM »
It came up as just text.

I reinstalled vsido and smxi cannot uninstall the nouveau drivers so it failed to install the drivers.

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: Cannot access tty1
« Reply #18 on: March 17, 2013, 07:17:26 PM »
Ok good....... now run smxi again. When nouveau is installed smxi will error the first time. This is normal

Sorry this has been such a pain in the ass  :)
Don't Be A Dick!

VastOne

  •      v-ger
  • Posts: 4197
    • View Profile
    • VSIDO Community
Re: Cannot access tty1
« Reply #19 on: March 17, 2013, 07:19:06 PM »
smxi cannot uninstall nouveau on the first time you run it... That is why both smxi and the How To I did says to run smxi video driver install section twice for it to succeed

Run smxi, install kernel (if you are), install nvidia drivers, reboot, start smxi again, go to nvidia driver install and install again, when done, start desktop
VSIDO      VSIDO FB     VSIDO Google+   

I dev VSIDO

VastOne

  •      v-ger
  • Posts: 4197
    • View Profile
    • VSIDO Community
Re: Cannot access tty1
« Reply #20 on: March 17, 2013, 07:20:03 PM »
lwfitz beat me to it...

Nice!  :)
VSIDO      VSIDO FB     VSIDO Google+   

I dev VSIDO

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: Cannot access tty1
« Reply #21 on: March 17, 2013, 07:29:47 PM »
Ive never had real good luck installing video drivers from the repo's, sometimes it works but at least in my experience more often than not it causes issues.
At least for the time being smxi is the way to go.
Don't Be A Dick!

Neon_Riots

  • Posts: 30
    • View Profile
Re: Cannot access tty1
« Reply #22 on: March 17, 2013, 07:41:58 PM »
Yes I can't believe I forgot to do that, I remembered as soon as I had to leave my computer for lunch.  It appears to have installed correctly now and tty1 is working.  I'm going to wait for a little bit before I mark this as solved, just in case I manage to do more stupid things in the mean time.

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: Cannot access tty1
« Reply #23 on: March 17, 2013, 07:47:52 PM »
AWESOME! Glad things are looking up!

We only learn by making mistakes.
Don't Be A Dick!

Neon_Riots

  • Posts: 30
    • View Profile
Re: Cannot access tty1
« Reply #24 on: March 18, 2013, 12:54:50 AM »
One small thing, I was trying to get steam working but it looks like I cannot install ia32-libs-i386 on sid, despite adding i386 multiarch support.  If I use
Code: [Select]
apt-get install libgl1-nvidia-glx:i386
I get a message saying that the nvidia-installer-cleanup wants to run but it just stalls and messes up dpkg.

Is this something I have to live with?  It's not a huge deal, but I can't find any solutions online that work with sid.

The specific steam error (when trying to launch a game) is
Code: [Select]
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.
EDIT:

Actually now that nvidia-cleanup-installer messed up dpkg I can't even uninstall it or use apt-get in general.  This is great.

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: Cannot access tty1
« Reply #25 on: March 18, 2013, 05:09:32 AM »
Whats the error your getting when you try to apt-get?

I dont have steam installed but once we get whatever is broken fixed then we can focus on that.
Don't Be A Dick!

Neon_Riots

  • Posts: 30
    • View Profile
Re: Cannot access tty1
« Reply #26 on: March 18, 2013, 05:16:39 AM »
Well I managed to get dpkg working again by killing dpkg and the installer.  Now I'm faced with reinstalling my nvidia drivers with smxi.  The problem is smxi reports that I have debian nvidia drivers/installer and refuses to work until I remove them.  Ive done apt-get remove --purge nvidia-* but that did not fix the issue.

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: Cannot access tty1
« Reply #27 on: March 18, 2013, 05:19:41 AM »
Hmmmm

Try dropping to tty and run

Code: [Select]
sudo sgfxi
Don't Be A Dick!

Neon_Riots

  • Posts: 30
    • View Profile
Re: Cannot access tty1
« Reply #28 on: March 18, 2013, 05:42:42 AM »
It gave me the same error.  Here is my sgfxi.log

EDIT: Alright false alarm, for some reason it didn't remove nvidia-installer-cleanup so I did that manually and now the nvidia drivers installed properly.

EDIT2: Attempting to launch steam now gives a fatal error because I'm apparently now missing
Code: [Select]
libGL.so.1

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: Cannot access tty1
« Reply #29 on: March 18, 2013, 05:58:15 AM »
Ok cool!

Im looking for a howto regarding steam on 64bit. I know I saw one recently


Don't Be A Dick!