Author Topic: SOLVED Upgrade Warning  (Read 7125 times)

zbreaker

  • Posts: 240
    • View Profile
SOLVED Upgrade Warning
« on: August 20, 2014, 01:30:59 AM »
Went  to du tonight and a whole lot of weirdness apparantly....kde???..think I'll lurk in the background for awhile...

Code: [Select]
Reading package lists... Done
W: GPG error: http://packages.siduction.org unstable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 15CBD88045C45076
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  kate-data katepart kde-runtime kde-runtime-data kdelibs-bin kdelibs5-data
  kdelibs5-plugins kdoctools libattica0.4 libdbusmenu-qt2 libdlrestrictions1
  libgpgme++2 libiodbc2 libkactivities-bin libkactivities-models1
  libkactivities6 libkatepartinterfaces4 libkcmutils4 libkde3support4
  libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
  libkemoticons4 libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4
  libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4
  libkpty4 libkrosscore4 libktexteditor4 libkxmlrpcclient4 libnepomuk4
  libnepomukcore4 libnepomukquery4a libnepomukutils4 libnl-route-3-200
  libntrack-qt4-1 libntrack0 libphonon4 libplasma3 libpolkit-qt-1-1 libqca2
  libqt4-declarative libqt4-designer libqt4-opengl libqt4-qt3support
  libqt4-xmlpatterns libqtwebkit4 libsolid4 libsoprano4 libssh-4
  libstreamanalyzer0 libstreams0 libthreadweaver4 nepomuk-core-data
  ntrack-module-libnl-0 oxygen-icon-theme phonon phonon-backend-vlc
  plasma-scriptengine-javascript soprano-daemon
The following packages will be upgraded:
  binutils cpp db5.1-util dbus dbus-x11 debhelper dmsetup dpkg dpkg-dev
  fakeroot ffmpeg fonts-opensymbol g++ gcc gcc-4.7-base gir1.2-gtk-3.0
  gir1.2-pango-1.0 ioquake3 libav-tools libavcodec55 libavdevice55
  libavfilter4 libavformat55 libavresample1 libavutil52 libavutil53
  libdbus-1-3 libdevmapper-event1.02.1 libdevmapper1.02.1 libdpkg-perl
  libfakeroot libfreerdp1 libgail-3-0 libgmp10 libgtk-3-0 libgtk-3-bin
  libgtk-3-common libid3tag0 libimobiledevice4 libjte1 libllvm3.4 libltdl7
  liblvm2app2.2 libpango-1.0-0 libpango1.0-0 libpangocairo-1.0-0
  libpangoft2-1.0-0 libpangoxft-1.0-0 libpixman-1-0 libpostproc52 libpython2.7
  libpython2.7-minimal libpython2.7-stdlib libpython3.4 libpython3.4-minimal
  libpython3.4-stdlib libreoffice libreoffice-avmedia-backend-gstreamer
  libreoffice-base libreoffice-base-core libreoffice-base-drivers
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-gtk libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-report-builder-bin libreoffice-sdbc-firebird
  libreoffice-sdbc-hsqldb libreoffice-style-galaxy libreoffice-style-tango
  libreoffice-writer librsvg2-2 librsvg2-common libswresample0 libswscale2
  libudisks2-0 libx11-6 libx11-data libx11-xcb1 lvm2 openarena-081-maps
  openarena-081-misc openarena-081-players openarena-081-players-mature
  openarena-081-textures openarena-085-data openarena-088-data openarena-data
  os-prober python-wxversion python2.7 python2.7-minimal python3-uno python3.4
  python3.4-minimal rsyslog udisks2 uno-libs3 ure wine wine1.7 wine1.7-i386
106 upgraded, 70 newly installed, 0 to remove and 0 not upgraded.
Need to get 643 MB of archives.
After this operation, 191 MB of additional disk space will be used.
Do you want to continue? [Y/n]

zbreaker

  • Posts: 240
    • View Profile
Re: Upgrade Warning
« Reply #1 on: August 21, 2014, 01:38:25 AM »
Has ANYone else experienced this?
I cannot imagine why apt sees a need to install this kde stuff. I have a stock VSIDO install for some time now and have d/u'd  uneventfully many times. Only thing ever added has been the Nvidia driver.

VastOne

  •      v-ger
  • Posts: 4221
    • View Profile
    • VSIDO Community
Re: Upgrade Warning
« Reply #2 on: August 21, 2014, 05:02:57 AM »
I would check installation logs and determine what has been installed that is pulling in all of KDE things... I would also check your sources list and verify something goofy has not happened there

It is a crazy one... I think jedi may have seen this quite a while back

Sorry I cannot be of more help    :(
VSIDO      VSIDO FB       

    I dev VSIDO

jedi

  • DEFCON 1
  • Posts: 1639
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: Upgrade Warning
« Reply #3 on: August 21, 2014, 05:14:58 AM »
I simply waited a day or two and it worked itself out.  Sorry I can't be more help...
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

zbreaker

  • Posts: 240
    • View Profile
Re: Upgrade Warning
« Reply #4 on: August 21, 2014, 12:40:03 PM »
Think I'll follow jedi's way until the start of the new week. If nothing resolves by then, I'll have to roll up my sleeves and get dirty.
I've become somewhat lazy using VSIDO ;)

PackRat

  • Posts: 2282
    • View Profile
    • PackRat configs on github
Re: Upgrade Warning
« Reply #5 on: August 21, 2014, 01:51:38 PM »
I had the same problem a while back too - actually twice once apt wanted to install kde, and the other time a bunch of gnome. All you can do is wait a few days for the broken package to get fixed.

Can't remember exactly what caused it - saw an explanation on the debian forum. As I recall, something "under the hood" got an upgrade and it throws a monkey wrench into the dependency requirements.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

jeffreyC

  • Posts: 58
    • View Profile
Re: Upgrade Warning
« Reply #6 on: August 21, 2014, 05:03:57 PM »
The last time with Gnome3 I think was OpenBox Gnome session having Gnome3 as a hard dependency.

zbreaker

  • Posts: 240
    • View Profile
Re: Upgrade Warning
« Reply #7 on: August 24, 2014, 09:22:51 PM »
Apt is still insisting on pulling in all of that kde cArp.......
Looks like I'll be rolling up the sleeves this week. Haven't met a linux challenge I couldn't beat 8)
Well....maybe that one time I tried a Gentoo install.

VastOne

  •      v-ger
  • Posts: 4221
    • View Profile
    • VSIDO Community
Re: Upgrade Warning
« Reply #8 on: August 25, 2014, 04:01:56 AM »
^ I would still hold out hope that in a day or so it would self clean

If not, have fun!
VSIDO      VSIDO FB       

    I dev VSIDO

jedi

  • DEFCON 1
  • Posts: 1639
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: Upgrade Warning
« Reply #9 on: August 26, 2014, 02:46:37 AM »
This is all very strange indeed zbreaker.  I have not seen this issue this time.  (KDE trying to install)
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

ozitraveller

  • Posts: 401
    • View Profile
    • Star
Re: Upgrade Warning
« Reply #10 on: August 26, 2014, 03:59:18 AM »
I found this :

https://wiki.debian.org/SecureApt

I seem to recall I've had this problem, and I just waited it out

jedi

  • DEFCON 1
  • Posts: 1639
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: Upgrade Warning
« Reply #11 on: August 26, 2014, 04:55:53 AM »
I just did an dist-upg about 2 hours ago, and I saw none of the KDE mentioned apps trying to install...
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

PackRat

  • Posts: 2282
    • View Profile
    • PackRat configs on github
Re: Upgrade Warning
« Reply #12 on: August 26, 2014, 12:29:15 PM »
edit: deleted - bad info.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

zbreaker

  • Posts: 240
    • View Profile
Re: Upgrade Warning
« Reply #13 on: August 26, 2014, 12:46:22 PM »
^
Think I'll give it a shot later tonight hopefully.
Attempted a d/u last night, but the kde onslaught was still present. Thanks for the tip.

PackRat

  • Posts: 2282
    • View Profile
    • PackRat configs on github
Re: Upgrade Warning
« Reply #14 on: August 26, 2014, 12:49:59 PM »
^ I made a mistake, oxygen icons are coming in with kde.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo