Author Topic: lxpanel covered by the windows  (Read 2086 times)

0day

  • Posts: 44
    • View Profile
lxpanel covered by the windows
« on: January 12, 2014, 11:42:47 AM »
LXPanel remains covered by the windows. how can I make it always visible? can i replace it with fbpanel?

hakerdefo

  • Posts: 525
    • View Profile
    • Looking at Linux through the Windows of Life
Re: lxpanel covered by the windows
« Reply #1 on: January 12, 2014, 03:17:54 PM »
Right click on the LXPanel then choose 'Panel Settings' from context menu. This will open 'Panel Preferences' window. Click on the 'Advanced' tab. Under 'Properties' section you will see two items,
1-> 'Make window managers treat the panel as a dock'
2-> 'Reserve space, not covered by maximized windows'
Check both this options.
This will prevent maximized windows from covering the panel and also it won't appear in the window switcher list.
Cheers. 
You Can't Always Git What You Want

0day

  • Posts: 44
    • View Profile
Re: lxpanel covered by the windows
« Reply #2 on: January 12, 2014, 03:47:37 PM »
done, don't work

PackRat

  • Posts: 2188
    • View Profile
    • PackRat configs on github
Re: lxpanel covered by the windows
« Reply #3 on: January 12, 2014, 07:00:46 PM »
There was a discussion about this a while back. Open the /home/username/.fluxbox/apps file and see if there is an entry for lxpanel that sets the layer. Comment it out and lxpanel will behave like you want.

Yes you can use fbpanel instead of kxpanel.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

0day

  • Posts: 44
    • View Profile
Re: lxpanel covered by the windows
« Reply #4 on: January 12, 2014, 10:33:21 PM »
[
[end]

changed in:
app] (name=panel) (class=lxpanel)
  [Layer]   {2}

to make it transparent?

PackRat

  • Posts: 2188
    • View Profile
    • PackRat configs on github
Re: lxpanel covered by the windows
« Reply #5 on: January 13, 2014, 01:41:14 AM »
fluxbox layers -

Each layer has a number. The named ones are: 2-AboveDock,
 4-Dock, 6-Top, 8-Normal, 10-Bottom, 12-Desktop.

You will want layer 2, 4, or 6 - maybe 8 - to keep lxpanel above the windows.

You should be able to search the forum for the thread where we figured this out to keep lxpanel below the windows. If you remove the layer setting from the ~/.fluxbox/apps file, the settings hakerdefo mentioned should work for you. If you go with fbpanel, that will function as a a panel as well becuse there isn't a setting in the ~/.fluxbox/apps file that manages fbpanel behavior.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

VastOne

  •      v-ger
  • Posts: 4182
    • View Profile
    • VSIDO Community
Re: lxpanel covered by the windows
« Reply #6 on: January 13, 2014, 03:27:36 AM »
These settings have also been made the default now in VSIDO for the last 6 weeks of ISO updates...

The lxpanel in VSIDO is also set as transparent by default

What ISO did you install with 0day?

VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO