Author Topic: inxi root requirement  (Read 16517 times)

VastOne

  •      v-ger
  • Posts: 4134
    • View Profile
    • VSIDO Community
Re: inxi root requirement
« Reply #15 on: January 18, 2013, 04:38:15 PM »
Run this in Xfce terminal

Code: [Select]
export PATH="$PATH:/sbin:/bin"
Then try to run inxi without sudo and let me know the results
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

jedi

  • DEFCON 1
  • Posts: 1604
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: inxi root requirement
« Reply #16 on: January 18, 2013, 06:17:24 PM »
Run this in Xfce terminal

Code: [Select]
export PATH="$PATH:/sbin:/bin"
Then try to run inxi without sudo and let me know the results

That took care of it for me VastOne.  In Xfce it now runs for me without root priveleges.
Code: [Select]
jed@jedsdesk:~$ export PATH="$PATH:/sbin:/bin"
jed@jedsdesk:~$ inxi
Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
CPU~Dual core Intel Core i7-2640M CPU (-HT-MCP-) clocked at 800.000 Mhz Kernel~3.7-trunk-amd64 x86_64 Up~5 days Mem~629.2/7899.7MB HDD~256.1GB(28.4% used) Procs~148 Client~Shell inxi~1.8.27 
jed@jedsdesk:~$ inxi -F
Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
System:    Host: jedsdesk Kernel: 3.7-trunk-amd64 x86_64 (64 bit) Desktop: Xfce 4.10.0 Distro: VSIDO
Machine:   System: Dell product: Dell System XPS 15Z
           Mobo: Dell model: N/A Bios: Dell version: A10 date: 02/20/2012
CPU:       Dual core Intel Core i7-2640M CPU (-HT-MCP-) cache: 4096 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Card-2: NVIDIA GF108 [GeForce GT 540M]
           X.org: 1.12.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 80x24
Audio:     Card: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: k3.7-trunk-amd64
Network:   Card-1: Intel Centrino Advanced-N 6230 [Rainbow Peak] driver: iwlwifi
           IF: wlan0 state: up mac: 88:53:2e:cc:f9:0c
           Card-2: Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c
           IF: eth0 state: down mac: 84:8f:69:cd:26:89
Drives:    HDD Total Size: 256.1GB (28.4% used) 1: id: /dev/sda model: LITEONIT_LCT size: 256.1GB
Partition: ID: / size: 25G used: 8.3G (37%) fs: ext4 ID: /home size: 125G used: 34G (29%) fs: ext4
           ID: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap
Sensors:   System Temperatures: cpu: 55.0C mobo: 55.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 148 Uptime: 5 days Memory: 629.6/7899.7MB Runlevel: 2 Client: Shell (bash) inxi: 1.8.27
jed@jedsdesk:~$ inxi -M
Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
Machine:   System: Dell product: Dell System XPS 15Z
           Mobo: Dell model: N/A Bios: Dell version: A10 date: 02/20/2012
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

VastOne

  •      v-ger
  • Posts: 4134
    • View Profile
    • VSIDO Community
Re: inxi root requirement
« Reply #17 on: January 18, 2013, 06:22:13 PM »
Thanks jedi

Now I need someone in Xfce to run this sequence and post the out put one at a time

Code: [Select]
echo $PATH
Code: [Select]
export PATH="$PATH:/sbin:/bin"
Code: [Select]
echo $PATH
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

mrneilypops

  • Posts: 106
    • View Profile
Re: inxi root requirement
« Reply #18 on: January 18, 2013, 06:29:55 PM »
Works for me too;
Code: [Select]
neil@vsido:~$ export PATH="$PATH:/sbin:/bin"
neil@vsido:~$ inxi -F
System:    Host: vsido Kernel: 3.7.0-2.dmz.1-liquorix-amd64 x86_64 (64 bit) Desktop: Xfce 4.10.0 Distro: VSIDO
Machine:   Mobo: Abit model: FP-IN9 SLI(C55-MCP51) version: 1.x Bios: Phoenix version: 6.00 PG date: 12/17/2007
CPU:       Dual core Intel Core2 Duo CPU E8400 (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx)
           Clock Speeds: 1: 1890.00 MHz 2: 1890.00 MHz
Graphics:  Card: NVIDIA G96 [GeForce 9500 GT]
           X.Org: 1.12.4 drivers: nouveau (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
           GLX Renderer: Gallium 0.4 on NV96 GLX Version: 2.1 Mesa 8.0.5
Audio:     Card: NVIDIA MCP51 High Definition Audio driver: snd_hda_intel Sound: ALSA ver: k3.7.0-2.dmz.1-liquorix-amd64
Network:   Card: NVIDIA MCP51 Ethernet Controller driver: forcedeth
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:50:8d:9e:ef:25
Drives:    HDD Total Size: 1188.3GB (1.7% used) 1: id: /dev/sda model: OCZ size: 60.0GB
           2: id: /dev/sdb model: OCZ size: 128.0GB 3: id: /dev/sdc model: WDC_WD10EADS size: 1000.2GB
Partition: ID: / size: 116G used: 9.4G (9%) fs: ext4
Sensors:   System Temperatures: cpu: 25.0C mobo: N/A gpu: 34.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 127 Uptime: 1 min Memory: 271.7/3952.5MB Client: Shell (bash) inxi: 1.8.27

Code: [Select]
neil@vsido:~$ echo $PATH
/home/neil/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/sbin:/usr/sbin:/home/neil/bin:/sbin:/usr/sbin:/home/neil/bin:/sbin:/bin

Code: [Select]
neil@vsido:~$ export PATH="$PATH:/sbin:/bin"
neil@vsido:~$

Code: [Select]
neil@vsido:~$ echo $PATH
/home/neil/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/sbin:/usr/sbin:/home/neil/bin:/sbin:/usr/sbin:/home/neil/bin:/sbin:/bin:/sbin:/bin

jedi

  • DEFCON 1
  • Posts: 1604
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: inxi root requirement
« Reply #19 on: January 18, 2013, 06:30:08 PM »
Here you go;

Code: [Select]
jed@jedsdesk:~$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/sbin:/usr/sbin:/home/jed/bin:/sbin:/bin

Code: [Select]
jed@jedsdesk:~$ export PATH="$PATH:/sbin:/bin"
jed@jedsdesk:~$

Code: [Select]
jed@jedsdesk:~$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/sbin:/usr/sbin:/home/jed/bin:/sbin:/bin:/sbin:/bin:/sbin:/bin
jed@jedsdesk:~$
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

VastOne

  •      v-ger
  • Posts: 4134
    • View Profile
    • VSIDO Community
Re: inxi root requirement
« Reply #20 on: January 18, 2013, 06:32:48 PM »
@jedi, was that done on another partition that you had not run this on before?

Code: [Select]
export PATH="$PATH:/sbin:/bin"
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

VastOne

  •      v-ger
  • Posts: 4134
    • View Profile
    • VSIDO Community
Re: inxi root requirement
« Reply #21 on: January 18, 2013, 06:37:37 PM »
This is very strange... all that

Code: [Select]
export PATH="$PATH:/sbin:/bin"
code is doing is adding /sbin:/bin to what is already there...

I need another test

For someone in Xfce who has not done anything yet to simply run from terminal

Code: [Select]
re
which is an alias for

Code: [Select]
source ~/.bashrc
Then try to run inxi -F again to see if that corrects it

VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

jedi

  • DEFCON 1
  • Posts: 1604
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: inxi root requirement
« Reply #22 on: January 18, 2013, 06:37:42 PM »
This was on my go to partition.  I had run inxi before but in Xfce it always wanted root priveleges.  I'd never tried it in OB.  I only ran inxi out of curiousity when I read the original post.  Today I saw your response, tried it, and now no root priveleges needed.
I can log into another partition and experiment if you need me too.  Still have 3 other "test builds" installed on sda5-sda8...  And it hasn't ever been ran on them....
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

Sector11

  • Posts: 870
    • View Profile
Re: inxi root requirement
« Reply #23 on: January 18, 2013, 07:09:12 PM »
^^ @ VastOne

Just re-installed VSIDO - Debian kernel, XFCE4 session...
Code: [Select]
sector11@sda1-2:~$ inxi -F
Error No: 1 - You must be root to run this script!
sector11@sda1-2:~$ re
sector11@sda1-2:~$ inxi -F
Error No: 1 - You must be root to run this script!
sector11@sda1-2:~$ $PATH
bash: /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/sbin:/usr/sbin:/home/sector11/bin:/sbin:/usr/sbin:/home/sector11/bin: No such file or directory
sector11@sda1-2:~$

brb with OB session on same install.... wait for it please.

OpenBox Session:
Code: [Select]
sector11@sda1-2:~$ inxi -F
Error No: 1 - You must be root to run this script!
sector11@sda1-2:~$ $PATH
bash: /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/sbin:/usr/sbin:/home/sector11/bin: No such file or directory
sector11@sda1-2:~$ re
sector11@sda1-2:~$ inxi -F
Error No: 1 - You must be root to run this script!
sector11@sda1-2:~$
Stay Home

jedi

  • DEFCON 1
  • Posts: 1604
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: inxi root requirement
« Reply #24 on: January 18, 2013, 07:14:53 PM »
This is very strange... all that

Code: [Select]
export PATH="$PATH:/sbin:/bin"
code is doing is adding /sbin:/bin to what is already there...

I need another test

For someone in Xfce who has not done anything yet to simply run from terminal

Code: [Select]
re
which is an alias for

Code: [Select]
source ~/.bashrc
Then try to run inxi -F again to see if that corrects it



In Xfce on a partition where inxi has never been run before;
Code: [Select]
jed@jedsdesk:~$ re

                                  User: jed
          _sudZUZ#Z#XZo=_         Hostname: jedsdesk
       _jmZZ2!!~---~!!X##wx       OS: Debian 7.0 x86_64
    .<wdP~~            -!YZL,     Kernel: 3.7.0-1.dmz.1-liquorix-amd64
   .mX2'       _xaaa__     XZ[.   Uptime: 0:02
   oZ[      _jdXY!~?S#wa   ]Xb;   Window Manager: Xfwm
  _#e'     .]X2(     ~Xw|  )XXc   Desktop Environment: Xfce
 .2Z`      ]X[.       xY|  ]oZ(   Shell: Bash
 .2#;      )3k;     _s!~   jXf`   Terminal: Xterm
  1Z>      -]Xb/    ~    __#2(    Packages: 1729
  -Zo;       +!4ZwerfgnZZXY'      CPU: Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz
   *#[,        ~-?!!!!!!-~        RAM: 465 MB / 7935 MB
    XUb;.                         Disk: 68G / 231G
     )YXL,,                       
       +3#bc,                     
         -)SSL,,                 
            ~~~~~                 
                                 
 
jed@jedsdesk:~$ inxi -F
Error No: 1 - You must be root to run this script!
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

VastOne

  •      v-ger
  • Posts: 4134
    • View Profile
    • VSIDO Community
Re: inxi root requirement
« Reply #25 on: January 18, 2013, 07:17:05 PM »
@jedi, you must have changed the re alias   ???
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

jedi

  • DEFCON 1
  • Posts: 1604
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: inxi root requirement
« Reply #26 on: January 18, 2013, 07:18:01 PM »
@jedi, you must have changed the re alias   ???
Haven't changed a thing other than archey at the bottom of .bashrc
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

VastOne

  •      v-ger
  • Posts: 4134
    • View Profile
    • VSIDO Community
Re: inxi root requirement
« Reply #27 on: January 18, 2013, 07:19:30 PM »
Please post your .bashrc

If re is showing archey then something is amiss
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

jedi

  • DEFCON 1
  • Posts: 1604
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: inxi root requirement
« Reply #28 on: January 18, 2013, 07:20:31 PM »
.bashrc follows...

Code: [Select]
# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
#[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
# We have color support; assume it's compliant with Ecma-48
# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
# a case would tend to support setf rather than setaf.)
color_prompt=yes
    else
color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    #alias grep='grep --color=auto'
    #alias fgrep='fgrep --color=auto'
    #alias egrep='egrep --color=auto'
fi

# shortcut to reload the font cache
alias fontreload='fc-cache -fv'

# some more ls aliases
#alias ll='ls -l'
#alias la='ls -A'
#alias l='ls -CF'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi
export PATH=$PATH:/sbin:/usr/sbin:$HOME/bin
archey
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

Sector11

  • Posts: 870
    • View Profile
Re: inxi root requirement
« Reply #29 on: January 18, 2013, 07:26:30 PM »
Jed - "re" read your bash script and the last thing in it was a command: archey

That's why you see it.

OK, I'm going back to "my system" now.
Stay Home