Author Topic: Disable the touchpad on a laptop while typing  (Read 1637 times)

PackRat

  • Posts: 2150
    • View Profile
    • PackRat configs on github
Disable the touchpad on a laptop while typing
« on: July 23, 2013, 07:42:25 PM »
syndaemon

Came across this little app today. I'm sure some of you are on laptops, and one thing that drives me nuts it that the mouse cursor will move as your palm or heel of your hand gets a little too close while typing. This little app takes care of that. It can be run as a daemon so add -

Code: [Select]
syndaemon -d
to your ~/.fluxbox/startup - or whatever startup file you use.

The result is that the touchpad is disabled when the keyboard is in use. By default, the touchpad will become active 2 seconds after keyboard activity stops. That can be chnaged -

Code: [Select]
syndaemon -i 1.0 -d
will cause the touchpad to become active after 1 second. There are some other options detailed in the man page. Worked like a charm when I tested it with geany and thunderbird.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

jedi

  • DEFCON 1
  • Posts: 1604
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: Disable the touchpad on a laptop while typing
« Reply #1 on: July 23, 2013, 08:07:59 PM »
Thanks a bunch PackRat!  I have a very sensitive touchpad on my Asus G55 laptop and this is a very frustrating issue.  (or was!)  Thanks for the fix/solution.
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

sqlpython

  • Posts: 70
    • View Profile
Re: Disable the touchpad on a laptop while typing
« Reply #2 on: July 24, 2013, 01:59:13 PM »
Yes, good solution, @Packrate

I had posted the same on #! a few months back with an add on.
http://crunchbang.org/forums/viewtopic.php?id=26254
 
  In that thread I have some brief instructions as to automating the action on Boot into OpenBox.
Hope that is of help to someone.
Stretch, Siduction-15.1,  Slackware 14.1, LMDE, Calculate 15.7

cobaltwolfe

  • Posts: 30
    • View Profile
Re: Disable the touchpad on a laptop while typing
« Reply #3 on: September 07, 2013, 03:52:40 AM »
This is amazing! I'm running a little Dell D430 and constantly have issues with hitting the touch pad. Big props for this.