Author Topic: The Vsido installlers and the non US users  (Read 5302 times)

Snap

  • Posts: 490
    • View Profile
The Vsido installlers and the non US users
« on: July 07, 2015, 05:43:05 PM »
I guess all this would be irrelevant for US users, most of you I guess. But maybe I'm not the only non US resident suffering this issue with the Refracta installer.

As you surely know vsido has two different installers. That's cool. The new Refracta installer and the old one, the Remastersys installer still around by users request.

I prefer the Remastersys per se. but aside of features, options and personal preferences. Every time I use the Refracta installer I have issues with my locales and keyboard layout. It never gets right. But it's not a Vsido issue. It also happens in other distros using this installer like Makulu. I usually have to face the locales setup after the installation is complete, but sometimes it refuses to behave anyone. Currently I cannot set my locale to anything. I tried all the regular methods and some other tricks I've found in the web. No way. Nothing worked.

I constantly get messages like this:

Code: [Select]
Can't set locale; make sure $LC_* and $LANG are correct!
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Code: [Select]
/etc/lsb-release: line 1: Jedi: command not found
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.utf8)
/etc/lsb-release: line 1: Jedi: command not found
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.utf8)
/etc/lsb-release: line 1: Jedi: command not found
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.utf8)
/etc/lsb-release: line 1: Jedi: command not found
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.utf8)
/etc/lsb-release: line 1: Jedi: command not found

Code: [Select]
bash: warning: setlocale: LC_ALL: cannot change locale (en_US.utf8)
root@vsido:/home/paco# env | grep LANG
LANG=en_US.utf8
GDM_LANG=en_US.utf8
LANGUAGE=en
root@vsido:/home/paco# export LANG=en_US.UTF-8
root@vsido:/home/paco# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en",
LC_ALL = "en_US.utf8",
LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)...
  en_US.UTF-8...cannot open locale definition file `en_US': No such file or directory
 done
Generation complete.
*** update-locale: Error: invalid locale settings:  LANG=en_US.UTF-8

Any ideas on how to solve it?

So, for non US users, better use the Remastersys installer. Locales are properly set during the installation process and never had a problem. I swear every day since I decided to give the Refracta installer another go... Damnit!

dizzie

  • DEFCON 1
  • Posts: 731
  • Bastard Operator From Hell
    • View Profile
Re: The Vsido installlers and the non US users
« Reply #1 on: July 07, 2015, 05:52:17 PM »
Do a reinstall locales. Worked for me, and I like my æøå so I had to :)


As for "Jedi" its a line in /etc/lsb_-release, you can change it, or ignore it. :)
Reclaim your culture, it's within your reach!

My Blog | Facebook | Twitter | G+ | VSIDO |

jedi

  • DEFCON 1
  • Posts: 1636
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: The Vsido installlers and the non US users
« Reply #2 on: July 07, 2015, 06:19:22 PM »
Hey Snap!  Sorry for your troubles.  I've been compiling my own Kernels lately and have also ran into the
Code: [Select]
/etc/lsb-release: line 1: Jedi: command not found error.  This is another of Debians nice little "feature additions" as I like to call all this idiocy thats been happening.  Simply open '/etc/lsb-release' with your "root" editor and change it from this;

Code: [Select]
DISTRIB_ID=VSIDO Jedi x64
DISTRIB_RELEASE=jedi
DISTRIB_CODENAME=jedi
DISTRIB_DESCRIPTION="VSIDO"

to this;

Code: [Select]
DISTRIB_ID=VSIDO
DISTRIB_RELEASE=jedi
DISTRIB_CODENAME=jedi
DISTRIB_DESCRIPTION="VSIDO"

Might fix your issue with the locales.  Of course you'd need to do this after the install to see if it would work.  So you'd need to know how to set the locales after the fact.  If you need more help don't hesitate to ask...
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

VastOne

  •      v-ger
  • Posts: 4191
    • View Profile
    • VSIDO Community
Re: The Vsido installlers and the non US users
« Reply #3 on: July 07, 2015, 08:54:04 PM »
I will fix this

Code: [Select]
DISTRIB_ID=VSIDO Jedi x64
to this

Code: [Select]
DISTRIB_ID=VSIDO_Jed_x64
Never seemed to be an issue before
VSIDO      VSIDO FB     VSIDO Google+   

I dev VSIDO

jedi

  • DEFCON 1
  • Posts: 1636
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: The Vsido installlers and the non US users
« Reply #4 on: July 08, 2015, 01:04:46 AM »
Or maybe this?

Code: [Select]
DISTRIB_ID="VSIDO Jed x64"
Linux hates spaces...
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

Snap

  • Posts: 490
    • View Profile
Re: The Vsido installlers and the non US users
« Reply #5 on: July 08, 2015, 05:19:58 AM »
Thanks, jedi. I've changed the lsb-release contents. Seems to behave now.

As for the locales the problem is still here. This seems to exactly my problem at first instance, but the proposed solutions didn't worked

https://www.thomas-krenn.com/en/wiki/Perl_warning_Setting_locale_failed_in_Debian

Code: [Select]
root@vsido:/home/paco# locale-gen en_US.UTF-8
Generating locales (this might take a while)...
  en_US.UTF-8...cannot open locale definition file `en_US': No such file or directory
 done
Generation complete.
root@vsido:/home/paco# localedef -i en_US -f UTF-8 en_US.UTF-8
cannot open locale definition file `en_US': No such file or directory
root@vsido:/home/paco# export LANGUAGE=en_US.UTF-8
root@vsido:/home/paco# export LANG=en_US.UTF-8
root@vsido:/home/paco# export LC_ALL=en_US.UTF-8
bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8): No such file or directory
root@vsido:/home/paco# locale-gen en_US.UTF-8
Generating locales (this might take a while)...
  en_US.UTF-8...cannot open locale definition file `en_US': No such file or directory
 done
Generation complete.
root@vsido:/home/paco# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US.UTF-8",
LC_ALL = "en_US.UTF-8",
LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)...
  en_US.UTF-8...cannot open locale definition file `en_US': No such file or directory
 done
Generation complete.
*** update-locale: Error: invalid locale settings:  LANG=en_US.UTF-8

I really don't know what happened this time. I always managed to fix it in the past...

I always use en_US in all my systems (many years before switching to Linux). It's easier for me this way. Better than using the typical crap es_ES translations apparently made by someone at the other side of the pond. It now feels natural to me.  Maybe the problem lies there. Setting a specific time zone and a keyboard layout but US English instead of the spected locales for the defined area... I really don't know. I'm tempeted to reinstall everything again using the other installer. Never an issue with this.

hakerdefo

  • Posts: 525
    • View Profile
    • Looking at Linux through the Windows of Life
Re: The Vsido installlers and the non US users
« Reply #6 on: July 08, 2015, 10:00:09 AM »
Hi there Snap,
I think the solution to your problem is simple. Open '/etc/environment' in your favourite text editor as root. And add following lines to it,
Code: [Select]
LANGUAGE=en_US.UTF-8
LC_ALL=en_US.UTF-8
LANG=en_US.UTF-8
LC_TYPE=en_US.UTF-8
Save the file. Next open '/etc/bash.bashrc' file in text editor as root and add following lines to it,
Code: [Select]
export LANGUAGE=en_US.UTF-8
export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8
export LC_TYPE=en_US.UTF-8
save the file and run the following commands,
Code: [Select]
sudo locale-gen en_US.UTF-8
sudo dpkg-reconfigure locales
Cheers!!!
You Can't Always Git What You Want

dizzie

  • DEFCON 1
  • Posts: 731
  • Bastard Operator From Hell
    • View Profile
Re: The Vsido installlers and the non US users
« Reply #7 on: July 08, 2015, 11:02:01 AM »
locale-gen how does it work exactly if the file(s) is/are missing?


Just reinstall the package "locale" and everything will work just fine!


Code: [Select]
apt-get install --reinstall locales
Reclaim your culture, it's within your reach!

My Blog | Facebook | Twitter | G+ | VSIDO |

zephyr

  • Posts: 130
  • Never lost, no matter where, you are there.
    • View Profile
    • https://sourceforge.net/projects/crowz/
Re: The Vsido installlers and the non US users
« Reply #8 on: July 09, 2015, 04:04:57 AM »
@dizzy@snap: Worked for me-thanks-zephyr
CROWZ / STAR / Devuan / refracta / VSIDO

dizzie

  • DEFCON 1
  • Posts: 731
  • Bastard Operator From Hell
    • View Profile
Re: The Vsido installlers and the non US users
« Reply #9 on: July 09, 2015, 06:57:21 AM »
Good stuff :)


and it's dizzie not dizzy :)
Reclaim your culture, it's within your reach!

My Blog | Facebook | Twitter | G+ | VSIDO |

Snap

  • Posts: 490
    • View Profile
Re: The Vsido installlers and the non US users
« Reply #10 on: July 09, 2015, 07:12:17 AM »
That did it here too. Thanks.

Anyway, borrowing the famous VastOne's conky phrase, replacing conky for Refracta installer.

zephyr

  • Posts: 130
  • Never lost, no matter where, you are there.
    • View Profile
    • https://sourceforge.net/projects/crowz/
Re: The Vsido installlers and the non US users
« Reply #11 on: July 10, 2015, 11:01:55 AM »
@dizzie: My most sincere apology, will have to keep that in check. Thanks again for the script.-zephyr
CROWZ / STAR / Devuan / refracta / VSIDO