VSIDO Community

VSIDO Controls => VSIDO Discussions => Topic started by: statmonkey on September 07, 2013, 04:58:42 AM

Title: Install fails to see swap partition (or how to get rid of gpt table)
Post by: statmonkey on September 07, 2013, 04:58:42 AM
My previous OS used an UEFI boot and a gpt partition table but my mobo bios allows for both UEFI and legacy bios boot.  I really hadn't paid much attention to this until I went to install Vsido and it failed. 

It was failing at the step where the install was asking the user to select the swap partition.  This was even though I had set up a swap partition in gparted.  After repeatedly reformatting the partitions to have larger swap partitions it finally dawned on me that perhaps I needed to try another method.  What follows is what eventually worked for me.

 This should work on any setup that offers UEFI and boot bios legacy.  If you are on a pure UEFI system you will have to create a UEFI mbr as http://semplice-linux.org/doku/semplice:users:uefi (http://semplice-linux.org/doku/semplice:users:uefi)  (ps good luck with that I got it to work on one box but it required a lot of TLC, also see this thread http://vsido.org/index.php/topic,322.0.html (http://vsido.org/index.php/topic,322.0.html) )  But most people should be able to use the following.

Notice: This solution expects that the drive you are planning on using for the install has been properly backed up.  Following this procedure will delete all data on the device.  REPEAT this will remove all that is on the drive.  If you haven't backed it up do so before proceeding.

Issue:

During the install when it comes to setting up the disks the Vsido installer does not see the swap partition even though it has been created in gparted, the result being the install screen will keep sending you back to set up a proper swap partition.  In this case a proper swap partition is one that isn't part of a gpt partition table.

Solution:

Change to a msdos partition table. 


     At this point you no longer have a gpt partition table (which is what UEFI uses) and our problem is pretty much solved. 
The rest of the steps are as normal.