VSIDO Community

VSIDO Support => General Support => Topic started by: VastOne on December 18, 2016, 09:58:36 PM

Title: hexchat icon strangeness
Post by: VastOne on December 18, 2016, 09:58:36 PM
I just switched from nouveau to nVidia and have found a strange situation with hexchat icons

(https://i.imgur.com/Xb5XFJ0m.png) (https://i.imgur.com/Xb5XFJ0)

You can see the white blob that is the icon on the tint2 panel.. the notification icon also does not show up .. but it is only for this app. I can run any other app that has notify and they work perfectly (pithos, transmission) .. To be clear, the icon is actually there and functional on the notification panel, it is just invisible

In my nouveau setup these icons worked flawlessly.. and the icons and app are where they are supposed to be.  nVidia was installed on this machine after removing nouveau so it definitely is a nVidia issue and not a hexchat issue

Any of you with nVidia run into anything like this at all? 

Turns out it was a hexchat issue that was resolved with the 2.12.3-4 release today
Title: Re: nVidia icon strangeness
Post by: PackRat on December 18, 2016, 10:26:18 PM
I think the problem is hexchat - both this desktop and my laptop are intel graphics and the hexchat systemtray icon has disappeared completely:

(http://en.zimagez.com/miniature/hexchat0.jpg) (http://en.zimagez.com/zimage/hexchat0.php)

I didn't capture the mouse in the shot, but a slot is created in the fluxbox systemtray and the "icon" is active. I can also bring up the context menu for hexchat if I click on it's space.

With multiple systray icons, there is even a "gap" for hexchat -

(http://en.zimagez.com/miniature/hexchat2.jpg) (http://en.zimagez.com/zimage/hexchat2.php)

Same behavior in tint2, dwm and i3 systemtrays (intel graphics). This is a recent issue for me, and I think Void just had a recent upgrade for hexchat.
Title: Re: nVidia icon strangeness
Post by: PackRat on December 18, 2016, 10:48:33 PM
Switched over to the desktop with the nvidia card - still Void linux. Same bevhavior; just a blank space for hexchat.
Title: Re: nVidia icon strangeness
Post by: VastOne on December 19, 2016, 12:00:20 AM
Thanks RatMan... I have context control of the invisible icon also on the systray.. can do anything with it except see it

the question is why is it working in nouveau only...

Strange one...
Title: Re: nVidia icon strangeness
Post by: VastOne on December 19, 2016, 12:18:37 AM
Bug Reported to Hexchat Devs and Debian 848615 (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=848615)

The last release on Dec 5th brought in a new maintainer replacing someone who had been doing it for years

This may be a transition bug
Title: Re: nVidia icon strangeness
Post by: VastOne on December 19, 2016, 12:57:33 AM
RatMan will you run hexchat from term and see if you get this message too?

Code: [Select]
(hexchat:10662): WARNING **: (pixmaps.c:104):load_pixmap: runtime check
failed: (pixbuf != NULL)
Title: Re: nVidia icon strangeness
Post by: PackRat on December 19, 2016, 02:24:18 AM
hexchat version  2.12.4
my upgrade came through on 12/14/16

terminal output:

Code: [Select]
** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)

** (hexchat:23994): WARNING **: (pixmaps.c:104):load_pixmap: runtime check failed: (pixbuf != NULL)
Title: Re: nVidia icon strangeness
Post by: VastOne on December 19, 2016, 02:28:25 AM
So this appears to be the issue... Jedi has a working version of the same build as I (2.12.3-3) and does not have this error

I was going to build the 2.12.4 version but looks as if there is no need since you have the newer version

I have passed this along to the dev also

Thanks RatMan
Title: Re: hexchat icon strangeness
Post by: VastOne on December 19, 2016, 08:49:16 PM
Turns out it was a hexchat issue that was resolved with the 2.12.3-4 release today
Title: Re: hexchat icon strangeness
Post by: PackRat on December 19, 2016, 09:12:05 PM
I'll let you know what happens when my upgrade comes through.
Title: Re: hexchat icon strangeness
Post by: VastOne on December 19, 2016, 09:41:53 PM
The devs response to the fix...

Quote
oh, seriously?

I really did nothing about this!

My response to him

Quote
There was also a hicolor-icon-theme update today... I was curious if this was involved too.. I could not be sure since the issue was only affecting hexchat...

In any event I am glad it is resolved
Title: Re: hexchat icon strangeness
Post by: PackRat on December 31, 2016, 01:46:58 AM
This issue appears to be fixed. You have the icon back in Sid?

Same version of hexchat, but no error messages in terminal. Must have been some other packages messing me up.
Title: Re: hexchat icon strangeness
Post by: VastOne on December 31, 2016, 01:48:16 AM
Yes.. fix a while back with an update to the hicolor icon set
Title: Re: hexchat icon strangeness
Post by: PackRat on December 31, 2016, 01:51:02 AM
Ok, I think I saw that hicolor icon update come through.
Title: Re: hexchat icon strangeness
Post by: VastOne on December 31, 2016, 01:55:31 AM
^ Love the new avatar!
Title: Re: hexchat icon strangeness
Post by: PackRat on December 31, 2016, 02:04:25 AM
My new look for winter.  8)
Title: Re: hexchat icon strangeness
Post by: VastOne on January 01, 2017, 05:04:28 PM
Got this update today from the hexchat developer (https://github.com/l3ib/nitrogen/issues/86#issuecomment-269909028)

Quote
@VastOne the fix is in master but not yet released. I'm trying to fix a few more issues before 1.6.1 is released (and can then be packaged).