Author Topic: Install fails to see swap partition (or how to get rid of gpt table)  (Read 2565 times)


  • Posts: 330
    • View Profile
My previous OS used an UEFI boot and a gpt partition table but my mobo bios allows for both UEFI and legacy bios boot.  I really hadn't paid much attention to this until I went to install Vsido and it failed. 

It was failing at the step where the install was asking the user to select the swap partition.  This was even though I had set up a swap partition in gparted.  After repeatedly reformatting the partitions to have larger swap partitions it finally dawned on me that perhaps I needed to try another method.  What follows is what eventually worked for me.

 This should work on any setup that offers UEFI and boot bios legacy.  If you are on a pure UEFI system you will have to create a UEFI mbr as  (ps good luck with that I got it to work on one box but it required a lot of TLC, also see this thread,322.0.html )  But most people should be able to use the following.

Notice: This solution expects that the drive you are planning on using for the install has been properly backed up.  Following this procedure will delete all data on the device.  REPEAT this will remove all that is on the drive.  If you haven't backed it up do so before proceeding.


During the install when it comes to setting up the disks the Vsido installer does not see the swap partition even though it has been created in gparted, the result being the install screen will keep sending you back to set up a proper swap partition.  In this case a proper swap partition is one that isn't part of a gpt partition table.


Change to a msdos partition table. 

  • To do so move through the install as normal until you get to the drive selection steps.
  •   Select the drive you want to install Vsido on, gparted will open to that drive.  Now we just have to create a new partition table
  • You should still be in gparted, select the drive that you want to use and highlight it. (It's probably already selected)
  • Then select Device from the gparted menu pulldown and select "Create Partition Table"
  • Gparted will prompt you with a "WARNING: This will ERASE ALL DATA on the ENTIRE DISK /dev/sdX" and "Default is to create an MS-DOS partition table" pop up.  This is exactly what we want.  In the lower corner select apply and the device will now show as a single drive unallocated in the gparted screen.

     At this point you no longer have a gpt partition table (which is what UEFI uses) and our problem is pretty much solved. 
The rest of the steps are as normal. 
  • Select Partition and create your new root and swap, plus home and whatever other partitions you want and then when you have it like you want select Apply.
  • Before closing gparted I always right click on my root partition and select "manage flags" and make sure that the system has a check in "boot" so it knows what that partition is for.
  •   Then close gparted when you are satisfied.  The Live Installer will pop up and this time present you with the partition that you set as swap.  Just select it and press OK.
  •   From there move on to complete the install.
    • I am not sure whether there are better ways to do this or not.  I did wrestle with the UEFI direct boot method but ran into two problems. 1. Any changes to grub at all resulted in the flashing cursor of death in the boot process. 2. The only way I could get it to boot was to write a script that I put in the UEFI mbr telling it where to look and what to do and when I started thinking about rewriting the bios to see that script automatically I realized what a black hole I was headed into.  But I did think about it .... that's crazy.