new install hangs at bleachbit


Hi All,

Bit of a noob here, or at best not a power user, and I'm finding that the new version of VSIDO hangs on my old desktop while setting up bleachbit 1.4-1. I'm trying to install it on an old Dell Dimension 3000, celeron processor/1 gig of Ram.

I was able to successfully install a previous version of VSIDO on an ACER ASPIRE with an AMD Semperon 3200+ and 512 meg of RAM.

I'm wondering if it's the new version of bleachbit, the old Dell, or (and this is way above my knowledge level) is systemd quite new and heavy?

I really like VSIDO on these old computer I have. Any ideas or comments are welcome.




Can you clarify this a bit more John?  Bleachbit is already installed on VSIDO.. are you saying that the installation of VSIDO is failing at some point or that you have installed it and now it is failing during a bleachbit situation...

VSIDO      VSIDO Change Blog    

    I dev VSIDO


Thank you for replying,

I said on the install, but it's on the post install and I believe it's updating bleachbit to version 1.4.1 (I think is the version). So, I've rebooted the computer and gone to Synaptic Package Manager and it throws an error and asks me me too dpkg --configure -a, which I've done (np there).

But, it kicks me out of the nice install script you've written before I've selected the options I'd like.

This issue has only come up in the last couple of weeks on VSIDO. I'll see if I can find an old version to try today to see if that happens.


I'm trying the 2014_JULY_22 version to see if I run into the same issue.

I'm also replicating the install with swap and ext 4 fs. If I have the same issue I'll try without swap and ext 2 fs.

As you can tell I don't know what's causing this, but I've installed and enjoyed VSIDO previously without this issue   :) .


I was just able to install the upgrade and choose the packages I wanted from the installer using the 2014 July 22 version. I don't know what changed between that one and the October versions.


The July 22 version appears to be working, but now I'm not able to reboot or shutdown. I wonder if that's the ext4 fs on this old computer. Should I try the install again again with ext2?

Any opinions or ideas are welcome,



Hi John

This is an interesting issue and one we will get to the bottom of

Bleachbit 1.4-1 is already installed on VSIDO so I am not sure why you are trying to reinstall it... I would start with a fresh install of the latest ISO (October 17 jedi version) using ext4  and let it run the vsido-welcome once it is installed

If it fails try to capture the exact messages and post them here... If you are able to fix the issue by running a dpkg --configure -a  all you need is to restart the welcome script at any time by running this in a terminal


Let me know what happens... this has me very curious

I did confirm that bleachbit 1.4-1 is installed on two new installs just this morning
VSIDO      VSIDO Change Blog    

    I dev VSIDO


Thank you VastOne,

The July 22 version has mostly worked. As I said above, I can't reboot or shutdown from Fluxbox, but I'd planned on trying JWM, which I've installed (with a bunch of x11 files for functionality) and I can logout of the WM and shutdown or reboot from the login window.

Now, I've got to learn how to configure JWM  ;D Google here I come.

Hopefully, I'll find some good JWM xml files I can copy bits and pieces of.

John J


There is no reason Jedi should not install fine and no reason you should not be able to run the latest and greatest on that box with Fluxbox.

I don't want to overstep my bounds but I don't think this is flux or Ext4 that is causing the problem.  I can't imagine why bleachbit would cause an issue on any old box nor why the install script would not work  I am not sure where the new install script logs itself but I would guess that you should be able to run the following after it fails in the script

tail -n 50 /var/log/syslog > sys.txt
tail -n 50 /var/log/apt/apt/history.log > apt.txt
tail -n 50 /var/log/dmesg > dmes.txt

and then attach those files here so I can have a look and see if the system is telling us what the issue is.  Alternatively you can look in those files yourself and probably tell us more.


^ Nice one statman.. thanks for the assist
VSIDO      VSIDO Change Blog    

    I dev VSIDO