Author Topic: Host Name - exim4 - Internal Mail - DNS issue?  (Read 1618 times)

jedi

  • DEFCON 1
  • Posts: 1636
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Host Name - exim4 - Internal Mail - DNS issue?
« on: February 05, 2014, 03:26:05 AM »
Not having troubles per se, but was wondering if someone smarter than me could point me to the file to fix this;

Code: [Select]
jed@vsido U=jed P=local S=294
My hostname is jedsdesk on my VSIDO install.  /etc/hosts and /etc/hostname both reflect that correctly...  However, I've had to reinstall 'exim4' in order to get the internal mail working.  This was the error just prior to re-installing 'exim4'.

Code: [Select]
jed@jedsdesk:~$ mail jed
Subject: test
test
Cc: 2014-02-04 20:43:28 1WArWS-00061S-Ci Cannot open main log file "/var/log/exim4/mainlog": Permission denied: euid=102 egid=105
2014-02-04 20:43:28 1WArWS-00061S-Ci <= jed@vsido U=jed P=local S=294
2014-02-04 20:43:28 1WArWS-00061S-Ci Cannot open main log file "/var/log/exim4/mainlog": Permission denied: euid=102 egid=105
exim: could not open panic log - aborting: see message(s) above
Can't send mail: sendmail process failed with error code 1

Advice/help appreciated!
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

VastOne

  •      v-ger
  • Posts: 4191
    • View Profile
    • VSIDO Community
Re: Host Name - exim4 - Internal Mail - DNS issue?
« Reply #1 on: February 05, 2014, 03:31:25 AM »
I am tracking this down with jedi

A solution has been found to fix the hostname

Code: [Select]
sudo dpkg-reconfigure exim4-config
and  running this fixes the mail issue

Code: [Select]
sudo install --reinstall exim4-base

I am now working on trying to see what the issue is on a brand new install and correcting it on the next ISO builds.
VSIDO      VSIDO FB     VSIDO Google+   

I dev VSIDO

VastOne

  •      v-ger
  • Posts: 4191
    • View Profile
    • VSIDO Community
Re: Host Name - exim4 - Internal Mail - DNS issue?
« Reply #2 on: February 05, 2014, 05:50:02 AM »
I built a bare metal install ... and set it up as jedi log in, jedi hostname

mail worked

Ran vsido-welcome and after each phase of installs I ran mail and it worked

Rebooted and mail still worked

Not a VSIDO issue...  ???

Jedi will get me the list of all the things he installed additionally and I'll test these as well

Cheers...
VSIDO      VSIDO FB     VSIDO Google+   

I dev VSIDO

jedi

  • DEFCON 1
  • Posts: 1636
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: Host Name - exim4 - Internal Mail - DNS issue?
« Reply #3 on: February 05, 2014, 11:54:42 AM »
I'll get on this today, and send to you ASAP!
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous