Author Topic: Intel Wimax  (Read 5580 times)

lwfitz

  • DEFCON 1
  • Posts: 1779
  • sudo rm -rf /
    • View Profile
Intel Wimax
« on: January 08, 2014, 08:18:16 PM »
The wireless card that I have has Wimax capabilities but I I am unable to get it functioning properly.

I ran

Code: [Select]
sudo apt-get install firmware-intelwimax which then made the wimax portion of the card recognizable but still not functionable.

Code: [Select]
ifconfig
only showed

Code: [Select]
luke@vsido-asus:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 20:cf:30:66:f9:f8 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:29 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3278 (3.2 KiB)  TX bytes:3278 (3.2 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:23:15:36:d8:68 
          inet addr:192.168.0.116  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::223:15ff:fe36:d868/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:22806 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15119 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:29532032 (28.1 MiB)  TX bytes:1620948 (1.5 MiB)   

but I could see it recognized

iwconfig
Code: [Select]
wmx0      no wireless extensions.

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"Wils Sport And Tackle" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 58:6D:8F:55:3B:B4   
          Bit Rate=130 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-40 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2809  Invalid misc:94   Missed beacon:0


So I ran

Code: [Select]
sudo ifconfig wmx0 up
iwconfig
Code: [Select]
wmx0      no wireless extensions.

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"Wils Sport And Tackle" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 58:6D:8F:55:3B:B4   
          Bit Rate=130 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-40 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2809  Invalid misc:94   Missed beacon:0

Which gave me


ifconfig

Code: [Select]
eth0      Link encap:Ethernet  HWaddr 20:cf:30:66:f9:f8 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:29 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3278 (3.2 KiB)  TX bytes:3278 (3.2 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:23:15:36:d8:68 
          inet addr:192.168.0.116  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::223:15ff:fe36:d868/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23374 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15571 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:30155199 (28.7 MiB)  TX bytes:1682334 (1.6 MiB)

wmx0      Link encap:Ethernet  HWaddr 64:d4:da:04:95:fc 
          UP NOARP  MTU:1400  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:20
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


iwconfig

Code: [Select]
wmx0      no wireless extensions.

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"Wils Sport And Tackle" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 58:6D:8F:55:3B:B4   
          Bit Rate=130 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-40 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2809  Invalid misc:94   Missed beacon:0

but still no wireless capabilities with wmx0.

My guess is that like in Windows when wifi is enabled then wimax is disabled. So my question is how would I disable wifi and enable wimax?


Code: [Select]
sudo rfkill list wimax
gives me

Code: [Select]
luke@vsido-asus:~$ sudo rfkill list wimax
1: asus-wimax: WiMAX
        Soft blocked: yes
        Hard blocked: no
3: i2400m-usb:1-1.1:1.0: WiMAX
        Soft blocked: yes
        Hard blocked: no

so as you can see wimax is blocked for some reason.

Any ideas?
Don't Be A Dick!

lwfitz

  • DEFCON 1
  • Posts: 1779
  • sudo rm -rf /
    • View Profile
Re: Intel Wimax
« Reply #1 on: January 12, 2014, 10:48:03 PM »
Interesting, nobody has any ideas on this? That's a first  :P
Don't Be A Dick!

PackRat

  • Posts: 2282
    • View Profile
    • PackRat configs on github
Re: Intel Wimax
« Reply #2 on: January 13, 2014, 01:19:44 AM »
Can you take down the wireless with:

Code: [Select]
ifconfig wlan0 down
then bring up your wmx0?

Are you using ceni? If so, you may be able to set the network interfaces in the /etc/network/interfaces either manually or with ceni - I don't know if ceni has an option not to bring up the interface. On reboot you may then be set.

Actually, now that I think about it some more, assign your wireless an ip address for a network you're not using in your shop/home. Then reboot so wlan0 is not active. You may be able to use ceni or wicd to bring up wmx0.

Something tells me you're going to have to use ceni and the /etc/network/interfaces file to make this work - some old school.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

lwfitz

  • DEFCON 1
  • Posts: 1779
  • sudo rm -rf /
    • View Profile
Re: Intel Wimax
« Reply #3 on: January 14, 2014, 07:19:59 AM »
Thanks Packrat Ill test this tomorrow. Taking the wireless down doesnt seem to make a difference but I havent had a chance to test with ceni. Will update asap.
Don't Be A Dick!

PackRat

  • Posts: 2282
    • View Profile
    • PackRat configs on github
Re: Intel Wimax
« Reply #4 on: January 14, 2014, 03:19:51 PM »
No problem -

I was doing some more research on this; looks like others have had to install some additional wimax tools to get it working - none of which seem to be in the repos; but sources available on 3rd party sites. Also saw some references to using network-manager since it has wimax support (some posts  - indicate that wimax support needs to be compiled into network-manager with --enable-wimax flag).

There are also references to installing the wimax stack - if that is not default, you might have to compile a custom kernel.

Of course, there is no frackin' HowTo for all this on the Debin wiki or user forum.

Good luck, Amigo.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

lwfitz

  • DEFCON 1
  • Posts: 1779
  • sudo rm -rf /
    • View Profile
Re: Intel Wimax
« Reply #5 on: March 08, 2014, 09:01:52 AM »
Been stuck at home with this fantastic flu that everyone seems to be getting (at least around here) and after sleeping for a couple days its now 1am and I feel it necessary to continue my quest to get wimax working properly.
Once I get this figured out Ill post a howto.
Don't Be A Dick!

VastOne

  •      v-ger
  • Posts: 4222
    • View Profile
    • VSIDO Community
Re: Intel Wimax
« Reply #6 on: March 08, 2014, 04:19:04 PM »
^ Hope you feel better mate... and I hope that is not Captain Trips you are dealing with in Cali

Feel better soon!
VSIDO      VSIDO FB       

    I dev VSIDO

dizzie

  • DEFCON 1
  • Posts: 731
  • Bastard Operator From Hell
    • View Profile
Re: Intel Wimax
« Reply #7 on: March 08, 2014, 05:03:50 PM »
Get well soon, i miss having you to kick around and pester :D
Reclaim your culture, it's within your reach!

My Blog | Facebook | Twitter | G+ | VSIDO |

lwfitz

  • DEFCON 1
  • Posts: 1779
  • sudo rm -rf /
    • View Profile
Re: Intel Wimax
« Reply #8 on: March 10, 2014, 07:21:25 AM »
Thanks guys! Im back and trying to get this nonsense worked out........... I wish Jedi was here to punch me in the face!


This is where Im at....

I got network-manager installed and seem to have support for wimax




and I added the wimax connection




I can run

Code: [Select]
sudo rfkill list
Code: [Select]
luke@vsido-asus:~$ rfkill list
0: asus-wwan: Wireless WAN
Soft blocked: no
Hard blocked: no
1: asus-wimax: WiMAX
Soft blocked: no
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
3: i2400m-usb:1-1.1:1.0: WiMAX
Soft blocked: yes
Hard blocked: no

but I still cant seem to unblock the wimax adaptor

I tried running

Code: [Select]
sudo ifconfig wlan0 down
Code: [Select]
sudo ifconfig wmx0 up
but I think I need wimax-tools which I dont have any clue how to get installed.  Wimax-tools is required to scan for Clear's network which is the one I need to connect to.


Don't Be A Dick!

PackRat

  • Posts: 2282
    • View Profile
    • PackRat configs on github
Re: Intel Wimax
« Reply #9 on: March 10, 2014, 01:06:52 PM »
Looks like wimax-tools needs to be compiled from source - libnl is a dependency and available in the repos.

Arch wiki has a link to debian source package - https://aur.archlinux.org/packages/wimax-tools/

there are also a bunch of git repositories; may be worth a search to find the official one - this one has some install instructions:  https://github.com/ago/wimax-tools - and looks to be the official git repo.

Take a look at the bodhi forums; There are a couple of threads where people are trying to get this to work - lots of commands to try to see if your wimax is being hard/soft blocked and getting the wimax unlocked. Latest one I saw was from 2012 though - I'd like to think all the patching and compiling that poor guy did is now part of the kernel and wpasupplicant.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

lwfitz

  • DEFCON 1
  • Posts: 1779
  • sudo rm -rf /
    • View Profile
Re: Intel Wimax
« Reply #10 on: March 11, 2014, 10:39:58 PM »
Done fighting this (at least for now) and going to just cancel my Clear account and invest in extra soothing menthol crab removing shampoo.

Thanks for the help PackRat
Don't Be A Dick!