Author Topic: PackRat's UTC issue with Windows 7  (Read 3263 times)

VastOne

  •      v-ger
  • Posts: 4191
    • View Profile
    • VSIDO Community
PackRat's UTC issue with Windows 7
« on: January 03, 2014, 11:32:26 PM »
I didn't want to bog down the systemd thread, or start a new one - so feel free to copy-n-paste this somewhere in the forum.

For dual booters of VSIDO and Windows 7 (Vista, 8?) there is an issue with VSIDO resetting the hardware clock to UTC; Windows needs it at local time. I've had this happen on my desktop (AMD) and laptop (i3) which are currently both dual boot linux-win7. I've since put Slackware on my desktop.

During the install, I have to make sure that I select that the hardware clock is set to local time. VSIDO will install fine with that, but at some point will reset the hardware clock to UTC which messes up the Windows clock - VSIDO still shows the local time. It's a bit of a pain to get it reset correctly.

I don't know if this is something in Sid or the VSIDO installer, or if it can even be tracked down. I noticed ntp is not installed by default in VSIDO, maybe that would be a fix?

I live in the western hemisphere, so there is no real damage - Windows time is moved forward so I have no files living in the future. An easy fix would be to move my Windows time zone to the west and make DST changes manually.

Of course, the best fix would be for MS to change Windows so it understands UTC an timezones. How about you get Gates and Balmer on a conference call and line them out.  8)

PackRat sent me that in a PM and I think it should be addressed by all... I do not have any windows installs to test

On my installs I have always said no to 'installed to local time' question and have never seen an issue with it

Anyone else seeing anything like this?

@PackRat, does installing NTP resolve it for you?

Gates and Ballmer have not answered my calls since Raptor went live...  8)
VSIDO      VSIDO FB     VSIDO Google+   

I dev VSIDO

statmonkey

  • Posts: 330
    • View Profile
Re: PackRat's UTC issue with Windows 7
« Reply #1 on: January 03, 2014, 11:52:54 PM »
Quote
Gates and Ballmer have not answered my calls since Raptor went live...

That's because they both "retired"  :P

I am not sure but I think Carrot Top is in charge there now.  You might try him.  For me no Win#$%$% to try it on.  I do have an Amiga 64 OS I play with sometimes but it handles UTC fine.

Don't you hate it when I am bored?

PackRat

  • Posts: 2255
    • View Profile
    • PackRat configs on github
Re: PackRat's UTC issue with Windows 7
« Reply #2 on: January 03, 2014, 11:59:55 PM »
@vastone -

So far so good.

for anyone else that runs into this issue, Post #61 in this thread usually works -

http://crunchbang.org/forums/viewtopic.php?pid=307991#p307991

and this page is useful - Edit 7/19/14 - link appears to be dead now

http://go.kblog.us/2012/10/to-correct-system-time-with-hwclock-and.html
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: PackRat's UTC issue with Windows 7
« Reply #3 on: January 06, 2014, 05:27:19 AM »
Thanks for this PackRat. I dualboot one machine for work reasons and hadnt been able to find a real fix for this (although I havent looked all that hard).

Don't Be A Dick!

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: PackRat's UTC issue with Windows 7
« Reply #4 on: January 08, 2014, 08:42:27 PM »
Ok I finally decided to do this but my clock wont sync properly. I now have a clock thats 4 hours fast and everything that I can find says its set to local (Los Angeles). 

Maybe if I leave it this way then everything I do will be in the future...........  ??? ???
Don't Be A Dick!

PackRat

  • Posts: 2255
    • View Profile
    • PackRat configs on github
Re: PackRat's UTC issue with Windows 7
« Reply #5 on: December 20, 2014, 06:20:13 PM »
I did a clean install of VSIDO Jedi on my desktop the other day; this happens to be the computer I dual boot with Windows 7. As usual, Debian (Fedora does this too, Slackware not so much) insists that the computer hardware clock be set to UTC even though I told the installer that the BIOS clock was set to local time - which Windows insists on. Since I don't share any files where a creation time would be an issue (only 5 hours difference any way) this is more of an annoyance than anything else.

This time around, since Windows is the culprit, I decided to fix the problem from the Windows side of the machine and leave Debian/VSIDO alone to do it's thing and keep the hardware clock set to UTC - which is preferable. From the Windows side there are two options -

1. Change your time zone to whatever makes the Windows clock show the right time - in my case, Windows thought the computer was in Hawaii.

2. Make Windows 7 understand that the hardware clock is set to UTC. This can be done with an edit to the registry - http://crashmag.net/configuring-windows-7-support-for-utc-bios-time

Use notepad so that the text is saved with the proper formatting and create a file with the following:

Code: [Select]
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
"RealTimeIsUniversal"=dword:00000001

sace as <filename>.reg   -> the .reg is required, I believe.

Start regedit (you will need an administrator password or appropriate permissions) and then import your filename.reg

Next time you log in, the Windows clock should be showing the proper time for your timezone; if you tried option #1 above, reset your time zone and then sync Windows from the clock settings.

For either method, uncheck the box that allows Windows to automatically adjust for Daylight Savings Time; some users have had trouble with that.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: PackRat's UTC issue with Windows 7
« Reply #6 on: January 09, 2015, 05:37:07 AM »
Nice work PackRat. I had forgotten about this problem and just got rid of Windows! Seemed easier lol
Don't Be A Dick!

PackRat

  • Posts: 2255
    • View Profile
    • PackRat configs on github
Re: PackRat's UTC issue with Windows 7
« Reply #7 on: January 09, 2015, 10:59:56 AM »
If only I could.

At some point the squeaky wheel just needs to be replaced.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo