Author Topic: Problems with locales & twice wicd launched  (Read 5540 times)

raphix

  • Posts: 9
    • View Profile
Problems with locales & twice wicd launched
« on: November 14, 2013, 07:50:06 PM »
Hello all !
I' m new on vsido distro and I apreciate a lot the work you've done ! Some members I seem to recognize from the #! forum ;)
I've got some tittle bugs with locale:
The time is good but the date is in http://fr.wikipedia.org/wiki/Afar_(langue) Afar ?
http://pix.toile-libre.org/upload/original/1383842564.png
I'm French... so I've changed the keyboard configuration with this in the autostart :
Code: [Select]
setxkbmap fr & It works fine but I'm in qwerty in the lightdm log session...
Is it possible to log with the french keybord settings (easier for the password) ?
Long life to vsido !
EDIT: oops I forgot the other little bug, when I start vsido openbox session I've got twice wicd icons in the tint2 sysrtay... No wifi connections are recognized with wicd and "ceni" works like a charm... Is it risky to unistall wicd and only use ceni ?

PackRat

  • Posts: 2282
    • View Profile
    • PackRat configs on github
Re: Problems with locales & twice wicd launched
« Reply #1 on: November 14, 2013, 09:51:11 PM »
It is not risky to uninstall wicd and use only ceni; but it would be better to remove it from the startup scripts in case you want to use it later. As long as you use one or the other, not both, you're good.

To get lightdm in French, I think you have to change the LANG environment variable, and the locale (see post below)

from debian wiki - https://wiki.debian.org/ChangeLanguage

Aren't one or two of the linuxBBQ group French? Maybe ask the question on their forum, they may have done exactly what you're trying to accomplish.

Bonne chance!
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

statmonkey

  • Posts: 330
    • View Profile
Re: Problems with locales & twice wicd launched
« Reply #2 on: November 14, 2013, 11:20:52 PM »
Welcome to Vsido!
I haven't tested this of late but I occassionally use a Thai keyboard and my notes say I did the following.
dpkg-reconfigure these apps/install if not there but pretty sure they are default.
locales and make sure that french is there
console-data and select the keyboard language from the arch list

I think that does it.  I apologize for not testing first but I am running systemd and I don't know yet how to do this since it requires some systemctl rewrites :(  I also have another method that worked for me in the past so if this doesn't work let me know.  Good luck.






raphix

  • Posts: 9
    • View Profile
Re: Problems with locales & twice wicd launched
« Reply #3 on: November 16, 2013, 03:04:41 PM »
Thanks for your answers... I crashed vsido when I wanted modified the "locale" with dpkg... Big bug, I don't understand why. The try was on a usb...
May be soon I will retry...  :'(

statmonkey

  • Posts: 330
    • View Profile
Re: Problems with locales & twice wicd launched
« Reply #4 on: November 16, 2013, 11:39:50 PM »
Just curious what the crash was?  I have had a little time and tested this and was able to set up French with no issues.  The error you got might give us a clue.  Check the dpkg.log.

raphix

  • Posts: 9
    • View Profile
Re: Problems with locales & twice wicd launched
« Reply #5 on: November 18, 2013, 12:22:26 PM »
the usb key has been lock in "read mode only" (no format possible with gparted, fsck, dd, or anything) after crash the shop gaves me another one because of the warranty, now I installed à #! on it and it's works fine.Unfortunatly I can not install vsido, but may be use some of configs of in crunchbang ? I really like the style of vsido.

ew

  • Posts: 67
  • Linux may very well be my midlife crisis :D
    • View Profile
Re: Problems with locales & twice wicd launched
« Reply #6 on: November 18, 2013, 03:26:06 PM »
I use these commands for all that keyboard-stuff.

"sudo dpkg-reconfigure keyboard-configuration"
"sudo dpkg-reconfigure console-setup" or "sudo dpkg-reconfigure console-data" ,
depending on which packages are installed on the system.

In addition(to generate locales):
"sudo dpkg-reconfigure locales"

If you play around with those, you should be able to fix it.
-ew
-----------------------------
 "What happens when you read some doc and either it doesn't answer your question or is demonstrably wrong? In Linux, you say "Linux sucks" and go read the code. In Windows/Oracle/etc you say "Windows sucks" and start banging your head against the wall."
--- Denis Vlasenko on lkml

ew

  • Posts: 67
  • Linux may very well be my midlife crisis :D
    • View Profile
Re: Problems with locales & twice wicd launched
« Reply #7 on: November 18, 2013, 03:38:53 PM »
As for the multiple wicd-gtk icons in openbox-session, I recall having that issue too, but as I should wipe my hdd to create a new partition-scheme, I didn`t bother to fix it. But I`m going to reinstall VSIDO a little later this evening, and rest assure. I will solve that issue, because someone as OCD as me can`t live with duplicate icons in the tray. I will report back when I fix it. Today, tomorrow or next year, but it will be fixed :D
-ew
-----------------------------
 "What happens when you read some doc and either it doesn't answer your question or is demonstrably wrong? In Linux, you say "Linux sucks" and go read the code. In Windows/Oracle/etc you say "Windows sucks" and start banging your head against the wall."
--- Denis Vlasenko on lkml

PackRat

  • Posts: 2282
    • View Profile
    • PackRat configs on github
Re: Problems with locales & twice wicd launched
« Reply #8 on: November 18, 2013, 08:36:06 PM »
for multiple wicd icons in the system tray, check /etc/xdg/autostart and see if there is a wicd.desktop file in there. If so, remove wicd from the openbox autostart and see if you only have the one instance.

You can also check the instances of wicd with -

Code: [Select]
ps -o user,pid,ppid,command -ax | grep wicd*
to see which process is starting the wicd-client.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

ew

  • Posts: 67
  • Linux may very well be my midlife crisis :D
    • View Profile
Re: Problems with locales & twice wicd launched
« Reply #9 on: November 18, 2013, 11:33:17 PM »
I don`t know if it`s that easy, because it`s only a issue in openbox-session. Not in fluxbox-session. But of course, it might be that Vastone has left it out of the fluxbox-autostart, but forgotten to do the same for the openbox-session. Anyway, I`m only guessing because it isn`t installed with me right now. I`ll do that now...
-ew
-----------------------------
 "What happens when you read some doc and either it doesn't answer your question or is demonstrably wrong? In Linux, you say "Linux sucks" and go read the code. In Windows/Oracle/etc you say "Windows sucks" and start banging your head against the wall."
--- Denis Vlasenko on lkml

PackRat

  • Posts: 2282
    • View Profile
    • PackRat configs on github
Re: Problems with locales & twice wicd launched
« Reply #10 on: November 19, 2013, 12:46:13 AM »
fluxbox doesn't normally read files from the /etc/xdg/autostart location (typo in my previous post) so you shouldn't be seeing two instances of wicd.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

VastOne

  •      v-ger
  • Posts: 4221
    • View Profile
    • VSIDO Community
Re: Problems with locales & twice wicd launched
« Reply #11 on: November 19, 2013, 05:34:37 AM »
I have not 'forgotten' to take out anything from the config from openbox and a simple look in it's startup will show

Code: [Select]
# wicd network manager
# (sleep 3s && wicd-gtk --tray) &

If there are any OpenBox users of VSIDO, perhaps one of them can trace this down
VSIDO      VSIDO FB       

    I dev VSIDO

dizzie

  • DEFCON 1
  • Posts: 731
  • Bastard Operator From Hell
    • View Profile
Re: Problems with locales & twice wicd launched
« Reply #12 on: November 19, 2013, 07:14:17 AM »
wicd-gtk --tray


Is what I use in pekwm, which kinda is like Openbox :)
Reclaim your culture, it's within your reach!

My Blog | Facebook | Twitter | G+ | VSIDO |

raphix

  • Posts: 9
    • View Profile
Re: Problems with locales & twice wicd launched
« Reply #13 on: November 19, 2013, 02:05:43 PM »
Thanks for all your anwers these might be very usefull if I retry vsido. For the moment I've installed #! waldorf on the usb-key because I feel more confortable for managing settings... May-be later I'll try vsido and "repos" for my country in .ch.

ew

  • Posts: 67
  • Linux may very well be my midlife crisis :D
    • View Profile
Re: Problems with locales & twice wicd launched
« Reply #14 on: November 20, 2013, 01:55:09 AM »
I have solved the two wicd-tray icons in openbox, at least for me.

As previously said in this thread, fluxbox doesn`t read from /etc/xdg/ autostart, so just remove the wicd-tray.desktop file from that location. As root cut and paste it somewhere so that you have a backup of the file if you ever should need it. When you have removed it for /etc/xdg/autostart, then logout and back in, just to test that it still works. If it does work, logout and change session to openbox and login.

In "~/.config/ openbox/autostart.sh", enable the wicd-tray entry, by uncommenting it, and save the file. Logout and back in to test that it works... If that works, then logout again, and switch session to xfce4, and login.

Right-click your xfce4-desktop, choose Settings/Session And Startup/ Application Autostart.... Click add, give it a name like wicd-tray or something, and in the command-field put this without the quotes "wicd-gtk --tray". Click ok, and logout and back in, to see that it works.... It works perfect for me, and what could break it is if a update/upgrade some day will put a new wicd-tray-desktop in /etc/xdg/autostart, but in that case, it`s just to delete it again...

The last session I haven`t looked at. Actually, I have nerver logged into it. But I suppose you can manuallyt set if for that session too..
-ew
-----------------------------
 "What happens when you read some doc and either it doesn't answer your question or is demonstrably wrong? In Linux, you say "Linux sucks" and go read the code. In Windows/Oracle/etc you say "Windows sucks" and start banging your head against the wall."
--- Denis Vlasenko on lkml