Author Topic: New Xorg updates have borked my Liqourix setup  (Read 6930 times)

VastOne

  •      v-ger
  • Posts: 4191
    • View Profile
    • VSIDO Community
New Xorg updates have borked my Liqourix setup
« on: July 26, 2013, 05:35:32 AM »
I just did a dist-upgrade and allowed it all to run... On my Liquorix boot, I get a login prompt and no X at all...  I have tried all my known magic and have yet to get X to load...  Including reinstalling the drivers via smxi, removing xorg.conf and wiping clean all kernel parameters on boot

This is a Nvidia machine, BTW

I ran the same updates on Debian Stock kernels and have not seen the issue

Just wanted to let you all know and be wary... I will keep you posted of any new developments
VSIDO      VSIDO FB     VSIDO Google+   

I dev VSIDO

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: New Xorg updates have boked Liqurix setups
« Reply #1 on: July 26, 2013, 06:33:18 AM »
Thanks VastOne. I was just about to update. You saved me some reinstall time Im sure

Edit:

Because Im a masochist I decided to let all the updates install and then rebooted with no problem.

I should also note that this is on

Code: [Select]
3.9-10.dmz.1-liquorix-amd64

and the Nvidia beta driver


Edit #2

I did just notice that Chromium is doing what I posted about a while ago, it crashes and kills Fluxbox.
Heres my x-session error

Code: [Select]
Xsession: X session started for luke at Fri Jul 26 00:13:44 PDT 2013
localuser:luke being added to access control list
xmodmap:  unable to open file '~/.Xmodmap' for reading
xmodmap:  1 error encountered, aborting.
tint2 : nb monitor 2, nb monitor used 2, nb desktop 1
Conky: desktop window (368) is root window
Conky: window type - panel
Conky: drawing to created window (0x1800002)
Conky: drawing to double buffer
Add launcher app: /usr/local/bin/.tint2oblaunchers/01-iceweasel.desktop
Add launcher app: /usr/local/bin/.tint2oblaunchers/02-terminal.desktop
Add launcher app: /usr/local/bin/.tint2oblaunchers/03-spacefm.desktop
Add launcher app: /usr/local/bin/.tint2oblaunchers/04-gmusicbrowser.desktop
Add launcher app: /usr/local/bin/.tint2oblaunchers/06-xfce menu.desktop
tint2 : nb monitor 2, nb monitor used 2, nb desktop 1
Loading LinuxLex-8. Icon theme : 'LinuxLex-8', 'Tangerine', 'gnome', 'hicolor',
Loading LinuxLex-8. Icon theme : 'LinuxLex-8', 'Tangerine', 'gnome', 'hicolor',
launcher.c 215: Using icon /usr/local/bin/images/firefox01-04.png
launcher.c 215: Using icon /usr/local/bin/images/WoBD Terminal.png
launcher.c 215: Using icon /usr/local/bin/images/phoca_thumb_l_file-manager.png
launcher.c 215: Using icon /usr/local/bin/images/gmb.png
launcher.c 215: Using icon /usr/local/bin/images/vsidoorb.png
launcher.c 215: Using icon /usr/local/bin/images/firefox01-04.png
launcher.c 215: Using icon /usr/local/bin/images/WoBD Terminal.png
launcher.c 215: Using icon /usr/local/bin/images/phoca_thumb_l_file-manager.png
launcher.c 215: Using icon /usr/local/bin/images/gmb.png
launcher.c 215: Using icon /usr/local/bin/images/vsidoorb.png
Conky: defining struts
[4345:4367:0726/001358:ERROR:object_proxy.cc(627)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[4345:4367:0726/001358:ERROR:object_proxy.cc(627)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[4345:4345:0726/001358:ERROR:object_proxy.cc(532)] Failed to call method: org.chromium.Mtpd.EnumerateStorages: object_path= /org/chromium/Mtpd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.chromium.Mtpd was not provided by any .service files
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 615 requests (615 known processed) with 0 events remaining.
      after 54007 requests (54003 known processed) with 0 events remaining.
[4345:4345:0726/001626:ERROR:chrome_browser_main_x11.cc(62)] X IO error received (X server probably went away)
[4518:4518:0726/001626:ERROR:x11_util.cc(117)] X IO error received (X server probably went away)
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 454 requests (454 known processed) with 0 events remaining.
real transparency on... depth: 32
xRandr: Found crtc's: 4
xRandr: Linking output DVI-I-1 with crtc 0
xRandr: Linking output DVI-D-0 with crtc 1
NO XSETTINGS manager, tint2 use config 'launcher_icon_theme'.
real transparency on... depth: 32
xRandr: Found crtc's: 4
xRandr: Linking output DVI-I-1 with crtc 0
xRandr: Linking output DVI-D-0 with crtc 1
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 60894 requests (60894 known processed) with 0 events remaining.
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 221983 requests (221983 known processed) with 0 events remaining.
[    11.39 ] error 3 (BadWindow) request 150 minor 7 serial 2763
[    11.39 ] error 157 (BadRegion) request 150 minor 17 serial 2764
[    11.39 ] error 157 (BadRegion) request 150 minor 14 serial 2765
[    11.39 ] error 157 (BadRegion) request 150 minor 10 serial 2766
[    11.39 ] error 3 (BadWindow) request 140 minor 5 serial 2771
[    11.39 ] error 3 (BadWindow) request 140 minor 5 serial 2779
Don't Be A Dick!

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: New Xorg updates have boked Liqurix setups
« Reply #2 on: July 26, 2013, 07:42:26 AM »
Definitely a bug in X-org. My machine is up and running but not totally stable.

Nvidia settings crashed on my so I ran it with

Code: [Select]
sudo nvidia-settings --sync
and this is the error I get when it crashes

Code: [Select]
luke@vsido-fx:~$ sudo nvidia-settings --sync
The program 'nvidia-settings' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 781 error_code 3 request_code 137 minor_code 4)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Ill run updates again tomorrow and see if we get a fix for this.
Don't Be A Dick!

hinto

  • Posts: 85
    • View Profile
Re: New Xorg updates have boked Liqurix setups
« Reply #3 on: July 26, 2013, 03:07:44 PM »
Yes they have.
I had to unwind it last night.
I got kernel panics on boot (on another distro) which I suppose was due to plymouth, X, Nvidia or a combination of them.
-Hinto
"If I have seen further it is by standing on the shoulders of giants." - Sir Isaac Newton

VastOne

  •      v-ger
  • Posts: 4191
    • View Profile
    • VSIDO Community
Re: New Xorg updates have boked Liqurix setups
« Reply #4 on: July 26, 2013, 03:12:06 PM »
I have done all I can to resolve this on my main partition to no avail...

I have tried plain nouveau... fail

I have tried debian-nvidia... fail

I have installed the debian 3.10 kernel... fail with all combinations of Xorg drivers ... fail

I have moved to another partition and ran all updates with no issues at all

Hopefully an update will hit soon to resolve
VSIDO      VSIDO FB     VSIDO Google+   

I dev VSIDO

hinto

  • Posts: 85
    • View Profile
Re: New Xorg updates have boked Liqurix setups
« Reply #5 on: July 26, 2013, 03:15:37 PM »
ah...
I am running a 3.8 generic Debian kernel.
-H
"If I have seen further it is by standing on the shoulders of giants." - Sir Isaac Newton

PackRat

  • Posts: 2255
    • View Profile
    • PackRat configs on github
Re: New Xorg updates have boked Liqurix setups
« Reply #6 on: July 26, 2013, 07:01:31 PM »
I ran the dist-upgrade on my HP i3 laptop, intel video, custom compiled 3.9.9 kernel.

No issues to date.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

VastOne

  •      v-ger
  • Posts: 4191
    • View Profile
    • VSIDO Community
Re: New Xorg updates have borked my Liqourix setup
« Reply #7 on: July 26, 2013, 07:27:58 PM »
It appears to be nVidia only?  Liquorix only?

Strange one indeed, yes...
VSIDO      VSIDO FB     VSIDO Google+   

I dev VSIDO

hinto

  • Posts: 85
    • View Profile
Re: New Xorg updates have borked my Liqourix setup
« Reply #8 on: July 26, 2013, 07:34:47 PM »
That was my combination.
-Hinto
"If I have seen further it is by standing on the shoulders of giants." - Sir Isaac Newton

PackRat

  • Posts: 2255
    • View Profile
    • PackRat configs on github
Re: New Xorg updates have borked my Liqourix setup
« Reply #9 on: July 26, 2013, 07:44:59 PM »
What is the current liquorix kernel version?

When I tried to install the nvidia drivers (from their site) for the 3.10.0 kernel (custom compile) on my debian testing desktop, it was a major fail. I didn't try to install with smxi. I ended up going with the 3.9.9 kernel and nvidia installed fine. It's an older nvidia card, 7-series.

Long story short, I'm thinking nvidia doesn't work too well with newer xorg or kernels.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: New Xorg updates have borked my Liqourix setup
« Reply #10 on: July 26, 2013, 07:58:01 PM »
Ummm Im not sure the exact kernel version for Liquorix but I am on the newest and via smxi the drivers install perfect (before last nights update). If you had nouveau installed then its normal for the install to fail. Just run the install again.
Don't Be A Dick!

PackRat

  • Posts: 2255
    • View Profile
    • PackRat configs on github
Re: New Xorg updates have borked my Liqourix setup
« Reply #11 on: July 26, 2013, 08:29:08 PM »
I black list the nouveau drivers, boot to console, install the nvidia drivers - no smxi.

Any time I update the kernel, I get to do that little song and dance. It was the method to use for slackware and I just kept doing it for debian.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

VastOne

  •      v-ger
  • Posts: 4191
    • View Profile
    • VSIDO Community
Re: New Xorg updates have borked my Liqourix setup
« Reply #12 on: July 26, 2013, 08:39:12 PM »
Latest Liquorix kernel is at 3.9-1

This used to happen every time there was an Xorg update 2-3 years ago but nVidia got a lot better with their delivery... I am sure it is a nVidia issue and a new driver will correct it soon enough

In the meantime, I am enjoying this VSIDO setup with Debians 3.10-1... Memory is low, CPU usage is low and no spikes in CPU or MEM while mouse usage or scrolling that DID pop back up with the liquorix kernel.  I am using stock Debian vid drivers and everything seems to be completely functional, no issues at all.  Long story short is that I will most likely stay with this setup

VSIDO      VSIDO FB     VSIDO Google+   

I dev VSIDO

VastOne

  •      v-ger
  • Posts: 4191
    • View Profile
    • VSIDO Community
Re: New Xorg updates have borked my Liqourix setup
« Reply #13 on: July 28, 2013, 12:10:28 AM »
As a wrap on this, I did not wait for the fix to come... I had everything on this drive backed up via fsarchiver and I restored it and stayed with the Debian kernel

A long way around to get back to ground zero, but nothing was lost in the end... (except my patience!)
VSIDO      VSIDO FB     VSIDO Google+   

I dev VSIDO

lwfitz

  • DEFCON 1
  • Posts: 1778
  • sudo rm -rf /
    • View Profile
Re: New Xorg updates have borked my Liqourix setup
« Reply #14 on: July 28, 2013, 07:38:20 AM »
I still had the original kernel installed from my install so I just dropped back to

Code: [Select]
3.9-1-amd64

and then reinstalled nvidia via smxi.

X-org seems back to normal now.

Don't Be A Dick!