Author Topic: Libreoffice Application Menu Not Visible  (Read 2232 times)

jedi

  • DEFCON 1
  • Posts: 1638
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Libreoffice Application Menu Not Visible
« on: January 14, 2013, 11:25:24 PM »
Logged into Xfce, my LO menus are also invisible.  Using the link above, I followed the suggestions but no joy.  I am hardly ever in Xfce anymore, so this isn't really an issue to me as it doesn't appear to be an issue in OB.  For an Xfce user though, I can see where they might consider this an annoyance.  I'm going to play around with the gtkrc file and see if I can come up with a fix.  Don't hold your breath anyone!  The file to fix (I think) is found at ~/.themes/SlicknesS/gtk-2.0/gtkrc

Quote from: VastOne
OK... I have 2 fixes, one definite and one a maybe.

First edit this ~/.themes/SlicknesS/gtk-2.0/gtkrc file do this

In gtkrc file at line 1256 (style "menu" section) change

Code: [Select]
bg[NORMAL] = "#d9d9d9"  (Or whatever is there)
to
bg[NORMAL] = "#000000" (I have also used #000001)

Second one is here and it appears this has been an issue for 5 years..  http://www.rebelzero.com/fixes/openofficeorg-dark-theme-workaround-with-ubuntu-804/8

I think it may be the second one needed to correct this

OK, heres the fix busprof's!  Took me and VastOne over an hour to figure this one out.  In the end it was pretty simple actually.  First, you have to go to your /home/YOURUSERNAMEHERE/.themes/SlicknesS/gtk-2.0.  Next find the file called gtkrc.  Open it with your favorite text editor.  Click on the find button and look for style "default".  In that section look for the following and make the appropriate changes as indicated below;

Code: [Select]
   fg[NORMAL]       = "#000000"
fg[ACTIVE]       = "#000000"
fg[PRELIGHT]     = "#000000"
fg[SELECTED]     = "#000000"
fg[INSENSITIVE]  = "#747474"

Change to the following;

Code: [Select]
   fg[NORMAL]       = "#FFFFFF"
fg[ACTIVE]       = "#FFFFFF"
fg[PRELIGHT]     = "#FFFFFF"
fg[SELECTED]     = "#FFFFFF"
fg[INSENSITIVE]  = "#747474"

Your LO menus should all be visible now.

Quote from: VastOne
Be aware that with this fix makes tabs,windows and menus in other areas of Xfce4 washed out.  A good example is what it does to the Appearance menu system under Settings/Appearance

If I had to use LibreOffice in Xfce4, I would find another theme...

Using something like gcolor2, you can change a couple of those settings to fix that as well.  I just did and changed them to a very nice VSIDO blue!
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous