Author Topic: [Solved]xfce-goodies  (Read 4035 times)

bodam

  • Posts: 11
    • View Profile
[Solved]xfce-goodies
« on: March 25, 2013, 03:23:23 AM »
I've been playing around with VSIDO in a VM.  I've noticed that a lot of the applets that are available on my Debian Testing XFCE box are missing off of this.  I think that the package called xfce4-goodies would add them, however when I try to install them I am getting the error below.  I'm sure how to fix.

bodam@bodam-vsido:~$ sudo apt-get install xfce4-goodies
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

Code: [Select]
The following packages have unmet dependencies:
 xfce4-goodies : Depends: xfce4-battery-plugin but it is not going to be installed
                 Depends: xfce4-clipman-plugin but it is not going to be installed
                 Depends: xfce4-cpufreq-plugin but it is not going to be installed
                 Depends: xfce4-cpugraph-plugin but it is not going to be installed
                 Depends: xfce4-datetime-plugin but it is not going to be installed
                 Depends: xfce4-diskperf-plugin but it is not going to be installed
                 Depends: xfce4-fsguard-plugin but it is not going to be installed
                 Depends: xfce4-genmon-plugin but it is not going to be installed
                 Depends: xfce4-mailwatch-plugin but it is not going to be installed
                 Depends: xfce4-mount-plugin but it is not going to be installed
                 Depends: xfce4-netload-plugin but it is not going to be installed
                 Depends: xfce4-notes-plugin but it is not going to be installed
                 Depends: xfce4-places-plugin but it is not going to be installed
                 Depends: xfce4-quicklauncher-plugin but it is not going to be installed
                 Depends: xfce4-sensors-plugin but it is not going to be installed
                 Depends: xfce4-smartbookmark-plugin but it is not going to be installed
                 Depends: xfce4-systemload-plugin but it is not going to be installed
                 Depends: xfce4-timer-plugin but it is not going to be installed
                 Depends: xfce4-verve-plugin but it is not going to be installed
                 Depends: xfce4-wavelan-plugin but it is not going to be installed
                 Depends: xfce4-weather-plugin but it is not going to be installed
                 Depends: xfce4-xkb-plugin but it is not going to be installed
                 Depends: xfce4-dict but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

VastOne

  •      v-ger
  • Posts: 4225
    • View Profile
    • VSIDO Community
Re: xfce-goodies
« Reply #1 on: March 25, 2013, 03:34:07 AM »
Xfce 4.10 is pulled from the Siduction repos that are a part of VSIDO

To get the goodies when they are available for 4.10 (they are not) you would need to pull them this way

Code: [Select]
sudo apt-get -t unstable xfce4-goodies
I do not expect them to be available until Wheezy/Testing goes stable, which could be in a week or so..  I would guess within a month of that Xfce 4.10 and all it's goodies will finally make it to Sid Proper

VSIDO      VSIDO FB       

    I dev VSIDO

bodam

  • Posts: 11
    • View Profile
Re: xfce-goodies
« Reply #2 on: March 25, 2013, 05:37:18 AM »
Thanks.  I'm new to SID so this is all new to me...

jefsview

  • Posts: 37
    • View Profile
Re: xfce-goodies
« Reply #3 on: March 25, 2013, 05:46:25 AM »
Many of the Xfce4-goodies have been deprecated, i.e. not built for 4.10. As the march continues towards Xfce 4.12, the best bet is to download and install them separately.

Personally, I like to pick and choose the ones I use and need.

-- Jeff

VastOne

  •      v-ger
  • Posts: 4225
    • View Profile
    • VSIDO Community
Re: xfce-goodies
« Reply #4 on: March 25, 2013, 01:17:32 PM »
^ Same here.. That goodies package adds way too many things  I do not need
VSIDO      VSIDO FB       

    I dev VSIDO