Author Topic: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST  (Read 459 times)

VastOne

  •      v-ger
  • Posts: 4181
    • View Profile
    • VSIDO Community
VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« on: March 27, 2019, 01:32:30 AM »
  • Updated VSIDO to latest Debian SID kernel – 4.19.0-4-amd64 #1 SMP Debian 4.19.28-2 (2019-03-15)
  • Updated all applications to the latest SID levels

All changes can be seen and discussed in the VSIDO Change sub forum

All files and torrents can be downloaded from the VSIDO Download page

________________________________


After nearly a year, I have made some changes..

There is only the x64 and x64_uEFI versions now and forevermore

We are up to kernel 4.19 and I anticipate going to 5 in the next month

The only known issues I am aware of is that grub stalls during the install with the following message

Code: [Select]
WARNING: Device /dev/sda1 not initialized in udev database even after waiting 1000000 microseconds
I think it is an installer issue related to what @filip fixed in locating the drives, I think the grub part of the installer also cannot find the drives but does the install fine anyway

I also have a new machine now, a uEFII machine donated to VSIDO by Luke / lwfitz so I can do all real time testing now onto HW

I also want to thank jedi, whose friendship and patience are one of the rocks behind VSIDO

Enjoy and please let me know of any issues
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

PackRat

  • Posts: 2181
    • View Profile
    • PackRat configs on github
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #1 on: March 27, 2019, 02:43:04 AM »
The uEFI iso boots just fine, but neither network manager nor ceni appear to be installed. So no easy wireless setup out of the box.

Will try them both tomorrow on a hard wired connection.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

VastOne

  •      v-ger
  • Posts: 4181
    • View Profile
    • VSIDO Community
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #2 on: March 27, 2019, 02:47:17 AM »
NM was never a part of VSIDO

ceni is now Ceni

Some dumbass thought it would be cute to rename it and not use any symlinks

sudo Ceni works fine
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

jedi

  • DEFCON 1
  • Posts: 1625
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #3 on: March 27, 2019, 06:16:16 AM »
Installed no issues at all.  Same with the stall at the grub part of the installer.  Installed fine anyway.  Rebooted, the new install is not in the current grub menu of course, logged into my goto and updated grub.  Instantly recognized the newly installed VSIDO, no errors on update-grub.  Rebooted, logged into new install ran ceni (what an asshole, ceni all along, now Cen?) setup the wifi, and came here to type in this update...  BRB
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

PackRat

  • Posts: 2181
    • View Profile
    • PackRat configs on github
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #4 on: March 27, 2019, 11:52:28 AM »
NM was never a part of VSIDO

ceni is now Ceni

Some dumbass thought it would be cute to rename it and not use any symlinks

sudo Ceni works fine

Ceni works.

Menu entries for Ceni and Network Manager Settings are broken, then.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

VastOne

  •      v-ger
  • Posts: 4181
    • View Profile
    • VSIDO Community
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #5 on: March 27, 2019, 11:55:37 AM »
Thanks, those I can control and fix

 8)
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

PackRat

  • Posts: 2181
    • View Profile
    • PackRat configs on github
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #6 on: March 27, 2019, 11:57:17 AM »
"Some dumbass thought it would be cute to rename it and not use any symlinks"

Where are you getting the package? Read that Siduction dropped ceni because it's no longer maintained and doesn't support ipV6. They may have renamed it as part of some packaging scheme.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo


PackRat

  • Posts: 2181
    • View Profile
    • PackRat configs on github
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #8 on: March 27, 2019, 02:19:39 PM »
Installed to legacy BIOS system. Had the usual issue of grub not installing to a location other than MBR, but other than that really smooth install. Ran update-grub in the ArchLabs install and it found VSIDO no issue. So I'll forgo the chroot and install grub for now.

Nice boot time for this ancient hardware:

Code: [Select]
Startup finished in 6.370s (kernel) + 25.027s (userspace) = 31.397s
graphical.target reached after 16.066s in userspace

no hangs.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

blaze

  • Posts: 81
    • View Profile
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #9 on: March 27, 2019, 03:25:03 PM »
Good news! Thanks, will check when schedule allows... ::)
blazingaway

PackRat

  • Posts: 2181
    • View Profile
    • PackRat configs on github
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #10 on: March 27, 2019, 11:57:32 PM »
Been using VSIDO off and on all day. No issues. Nice and stable.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

VastOne

  •      v-ger
  • Posts: 4181
    • View Profile
    • VSIDO Community
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #11 on: March 28, 2019, 03:05:03 AM »
For those who want it here is  fix for Ceni / ceni so that you won't have to change any menus... Run the following to create a ceni symlink

Code: [Select]
sudo ln -s /usr/sbin/Ceni /usr/local/bin/ceni
Keep in mind you must know roots PW in order to run ceni.. In VSIDO default you must change the root PW to know it by running:

Code: [Select]
sudo passwd root
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

VastOne

  •      v-ger
  • Posts: 4181
    • View Profile
    • VSIDO Community
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #12 on: March 28, 2019, 11:35:05 AM »
Been using VSIDO off and on all day. No issues. Nice and stable.

Excellent news RatMan, thank you!
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

PackRat

  • Posts: 2181
    • View Profile
    • PackRat configs on github
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #13 on: March 28, 2019, 01:54:58 PM »
Been using VSIDO off and on all day. No issues. Nice and stable.

Excellent news RatMan, thank you!

Borked it trying to install nvidia drivers (the more things change, the more the stay the same), issue with the initramfs-tools again. System still booted and ran, but I hate that error message during upgrades so did a new clean install. Will stick with nouveau since I won't be gaming on this computer.

During the new install, I used the legacy BIOS iso (uEFI iso on the first one) and the installer kept crashing - 3 tries. Crashes at the end of the disk partioning section, or right afterwards when it's suppose to start uncompressing the image.

Went back to the uEFI iso and it went through to completion no problelms.
I am tired of talk that comes to nothing.
-- Chief Joseph

...the sun, the darkness, the winds are all listening to what we have to say.
-- Geronimo

jedi

  • DEFCON 1
  • Posts: 1625
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: VSIDO x64 and x64_uEFI ISO’s updated 2019-MAR-26 14:16 CST
« Reply #14 on: March 28, 2019, 08:55:58 PM »
The uEFI live boot went perfectly.  I did not even have to go into bios to get it to see the liveUSB! Straight to grub it went!  Default booted to the first selection, no problems or errors seen during the boot, ran (C)ceni, then installed.  (I was a little disappointed to not see 'efibootmgr' installed on the live media.)  Speaking as a mobile VSIDO user (2 laptops) it is nice to see some sort of indicator that your wireless is connected.  Is wicd still maintained?  Or is there another way to see at a glance if the connection is alive while in the fluxbox GUI?

Setup a '/' a '/home' and a '/boot/efi' from the installer. 2 out of those three partitions already existed.  The '/' I created using the installers disk tools, chose a current and already existing/used/goto '/home' and a currently existing and working '/boot/efi'.  So the disk tools (manual Geeks Paradise? choice in the installer) worked fine for me.  I never opened Gparted, before or after the install.  Got the long pause during the bootloader install which I expected, it completed (i did not see errors because i used the menu selection to install) and i rebooted.

On reboot the regular boot occured without seeing the newly installed VSIDO as I knew it would not.  Logged into my regular goto, update-grub, reboot, voila, it is now in the grub menu of course, into the new install, everything is beautiful not to steal song lyrics or anything.  So nice to leave chroot in the dust!  --BIND this!

I notice on reboot that the first time I run a root task as my user in terminal, I still have to use the vsido live password.  After I've used vsido as the pw, mine then works after that as well as roots.  Just thought it weird enough to mention.  I do a passwd change on both after the install anyway.  All of this brought to you on real metal, a MSI Laptop.

Just a cut/paste really, of what is installed and what is not during the vsido-welcome...


cups cups-pdf system-config-printer printer-driver-hpijs ;  installed from vsido-welcome

openjdk-6-jre icedtea6-plugin ; does not install (i think java is up to 8? and icedtea6 is also a higher ver now)

libreoffice libreoffice-gtk ; should be libreoffice-gtk2 now or libreoffice-gnome?  IMO your better off removing this option.  Easily installs from apt-get.

git git-gui git-cvs git-svn git-email mercurial subversion subversion-tools bzr bzrtools cvs thunar-vcs-plugin geany version control tools ; installed from vsido-welcome

openssh-server ; installed from vsido-welcome

apache2 mysql-server php5 php-pear php5-gd php5-mysql php5-imagick php5-curl curl phpmyadmin rsync cronolog ; none of the LAMP stack part installs
E: Package 'php5' has no installation candidate
E: Package 'php5-gd' has no installation candidate
E: Package 'php5-mysql' has no installation candidate
E: Package 'php5-imagick' has no installation candidate
E: Package 'php5-curl' has no installation candidate
and so on etc...

build-essential debhelper cdbs dh-make diffutils patch gnupg fakeroot lintian devscripts dpatch dput quilt zenity clipit bashburn keepassx numlockx ; installed from vsido-welcome

gimp inkscape mtpaint shotwell darktable rawtherapee ; gimp does not install because gcolor2 is not available. remove it and the rest will install just fine.




Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous