Nvidia Install Problems


Here is my hardware:



CPU (AMD 8370



32gb DDR3 2133 (PC3 17000)

Video Card




two 1tb Seagate 7200rpm storage drives

Power Supply

CORSAIR CX series CX750 750W

I have two issues.

1) This is a new MB and I cannot boot up with a live disk to install. Everything seems to load fine and then the screen goes black and my monitor goes to sleep. I had this with the old MB and I was able to use the onboard video to get it installed, install the Nvidia driver and then use my video card.
Unfortunately this board doesnt have onboard video. Without using a different card to install with does anyone have any ideas how to get installed?

2) Every time I install for the last few releases, grub wont boot my system. I boot up and before I get to the grub screen I get a flashing cursor and thats it. I end up having to use a dirrent distro, install on a seperate disk, use that distro to boot VSIDO and from there purge grub and reinstall it (sometimes more than once) and finally I can boot up.

To make things even weirder, I can boot up just fine when booting in uefi mode and this video card. Just not in bios mode
Don't Be A Dick!


I have a quite similar system (only older). The uefi/bios of these mobos are darn complex. It took me a good while to get used to it. Now that time went by and it works fine I forgot how the heck I did it. But from the top of my head I remember that I had to disable secure boot and enable hybrid legacy+uefi mode in order to boot both types of distros. Also the drive selection/boot order is a bit of a mess. It can drive you crazy until you figure it out.

Hope these crap tips help. If you need it I can poke into my uefi/bios for you and check the exact settings. My rig now boots anything you throw at it.


Specific changes coming in kernel 4.8 due to be released imminently (debian) may offer some help. As soon as it is released I will make an ISO

QuoteAMDGPU OverDrive support for overclocking AMD graphic cards
NVIDIA Pascal support, which includes only initial support
Raspberry Pi 3 SoC supported by mainline kernel
ACPI Low-Power Idle support
HDMI CEC support after years of development
Btrfs ENOSPC improvement
Hardened usercopy protection
ASLR for kernel memory sections
Microsoft Surface 3 touch support
Intel Virtual Button driver for Skylake laptops
VSIDO      VSIDO Change Blog    

    I dev VSIDO


Thanks VastOne! I finally found an old video card so I'm gonna try to get installed tonight.

@ Snap, thanks for the tips. I don't think its an efi setting on the board as I have had the same issue with the past two boards.
I'm with VastOne in that I think its either a kernel or grub issue ( at least as far as the second issue goes).

The first issue is an nvidia issue I'm sure

Don't Be A Dick!


This is a rough guidline for a bios setup that will cause the least headaches,

Bios -> Boot -> Secure Boot -> Select 'Other OS' -> Save changes. Next go to,

Bios -> Boot -> Boot Override -> CSM -> Boot Option Filter -> Select 'UEFI and Legacy' -> Save changes

Bios settings and menu differ from model to model but the above should be good enough to guide you in the general direction :)

You Can't Always Git What You Want


Thanks Hakerdefo

That's exactly the settings I have. I think I have figured out the grub issue, well, kind of figured it out.
I installed yesterday and everything went great. I rebooted multiple times and was so excited to finally be back up and working that it it dawn on me to make sure grub was actually installed to the MBR of the drive I was using. I wiped the other drive that I had windows on and then I couldn't boot. No bootable disk. Hmmmmmmm.....

I went in via chroot and tried to reinstall grub but kept getting an error so I said screw it and I reinstalled. I disconnected all unnecessary drives as to eliminated any possible headache. Everything went good with the install so I rebooted and got the same error. No bootable drives.
I continued this for another couple install attempts using both installers and had no luck.

It was the alternate installer that tipped me off. I kept getting a warning that grub failed. So I installed via the main installer and then grabbed a super grub disk and dd'd it to another USB drive.
Super grub was unable to detect any grub installation. So no wonder it won't boot! Using rescutux I attempted to repair/reinstall grub but it just errored and chroot didn't work either.

Don't Be A Dick!


Hi lwfitz,
Boot via live image of VSIDO and check the existance of,
If it is present then you have booted using EFI/UEFI and in its absense we can conclude that you have booted-up via BIOS.

To reinstall Grub2 in UEFI,

And in BIOS,


You Can't Always Git What You Want


^ thanks for the help. I got installed earlier on bios. Tomorrow I'm gonna see if I can get this to work on uefi.

Don't Be A Dick!