Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - paxmark1

Pages: [1]
1
WM Designs and Discussions / Re: E17 Window Manager
« on: July 02, 2016, 03:16:26 PM »
May serendipity happen to all 

For reasons unknown to me, I just tried another kick at the can at Enlightenment.  I used the guide at

https://www.enlightenment.org/distros/debian-start

The compile fails as it is missing libpoppler-cpp0v5 which I got via installing libpoppler-cpp-dev.  I recompiled.

It was compiled (slowly) on an Asus aspire atom (i386) with 1Gb of ram in testing (stripped down sparky with lxqt) and it compiled without too many error messages.  I did get some wicked error messages when it shifted to the compile of terminology.  Trying various "startx blah" did not work, but mousing over to Session in sddm and selecting Enlightenment started it up and terminology is no slower than when I did apt-get install e17 maybe a year ago. on this machine.  If the howto is focused on a debian stable environment, well that is a pretty good script they have. 

It says E21 0.21.99.21536 - I believe I got it pretty much as E21 arrived.  Terminology is 0.9.99 versus 0.7.0-1 in Debian. No, it needs different compile flags than in the how to for wayland and weston. Of course since it is in /usr/local without .deb's apt-cache will not show the correct version numbers.   What am I going to do with it.  Probably nothing.  I am an old dog who does not want to learn new keystrokes.  It has too much overhead for an atom and I do not wish to install on anything else.  But for people who want to kick the tires of Wayland, well, maybe it is a bit easier now.  Still looks like a bit of work and a bit of reading.  Peace out.





 

2
VSIDO Installation Help / Re: OOPS Major headache
« on: August 09, 2015, 03:00:42 AM »
And the VSIDO iso of July 26 would be a few mere days prior to the August 01 start of libstdc++6 transition.  That one might work better than an old one.  Whole lot of waiting going on in Sid these days.

Note Once installed apt-get upgrade and even apt-get install flactag (etc. etc.) will cause your machine to break via updating the gcc and flushing many programs (like libre-office) down the drain.   

3
General Support / Re: Network and all cards/hardware GONE
« on: June 22, 2015, 03:31:42 AM »
Yeah, it got wonky for me with ceni  and wifi after systemd 215-18 and the jump to 220-x. I did delay on that jump.  I have gone to connman to configure wifi (eth0 is dhcp and it does it automagically for me) on 2 testing and one sid(uction) machine  Others posting elsewhere who used ceni are going to the cli of network-manager or configuring the networking service of systemd.   All 3 have a specific service set up for systemd to use, just don't use 2 services.  So far connman (using the interface connmanctl) works on (1)my testing wayland-weston hdd, (2)a sparky testing kde on a netbook (using the qt gui cmst for connman) and (3) on an amd netbox with sid(uction) and lxqt.  ceni is just not going to function that well with systemd, and my guess for wicd (I did take a peek at the git page) is that it is not that well suited for systemd either. 

I think an analogy is that the usage of init 3 and init 5 in a tty worked for a while with systemd, but now starting weeks ago using init3 and 5 for me  killed eth0 and then later polkit and I would have to restart the internet in ~/. 

One possible undocumented thing about connman is that using "connman agent on" does not work to enter the script to enter your psk phrase.  However using the interreactive interface connmanctl <enter>  new line > agent on  will bring up the script to enter the name of the passphrase after you ask to connect the wifi service. 

peace

4
VSIDO Installation Help / Re: init 's scrambled
« on: November 26, 2014, 05:14:07 AM »
The dbus update did fix some things.  I also added policykit1 and udisks2 via apt-get. They were removed in the autoremove.  Checking with bootupmanager I saw that wicd was somehow still installed, deleted its start at boot and removed it and all programs with wicd in it's name.  I did not autoremove the python dbus and gobject programs.   Ceni is working well with the wlan0

I misspoke in previous post.  VLC was deleted when I was playing with Siduction.  Gmusic browser was apt-get removed.  However it would come up when hit by accident in menu.  I just did an apt-get purge on it.  That should stop.  Haven't put in deadbeef yet. 

The flux box environment still works well
 
systemd-cgls now gives results  the same as ps xawf -eo pid,user,cgroup,args in gui terminal and Rescue terminal. 

who -r    gives run-level 2  2014-11-25 18:56                   last=S          from root and user terminals in gui

but systemctl  daemon-reload  and systemctl reload httpd.service both give
Code: [Select]
Failed to get D-Bus connection: Unknown error -1
and journalctl  =b still gives
Code: [Select]
No journal files were found.  This is after adding a journal directory to the proper place and then going into the correct /etc conf file and changing journaling from auto to persistent.    So it goes. 





5
Introductions / Hey y'all
« on: November 26, 2014, 01:43:06 AM »
Started with caldera, then Mandrake to Mandriva b.s. and then Ubuntu when it was ok.  And then #!  I quit KDE because of neepomuk.  No, I am not that great at it, can't code or anything, but I like foss. 

Yeah, if I am going to have my feet in the water on one machine, well, maybe it is time to abandon debian testing.  I will remain on stable on my main machine as usual.  This seems a good enough place to hang a hat some days. 

Activists I miss are Phil Berrigan, Samuel Day (long ago editor of Bull Amer. Atomic Sci) and Sen. Paul Wellstone.  But I live in Canada.  Would have been nice to have met Jack Layton.  But, I won't be talking any more about that here.  period. 

I spent a few years living with the homeless.  Sheltered a lot of Korean and Viet War vets, but since then mostly I have been working with the mentally challenged the last two decades.   I lived in the same houses with them for 13 years. 

I think I will fit in here.  peace.  Mark

6
VSIDO Installation Help / Re: init 's scrambled
« on: November 25, 2014, 11:28:57 PM »
more sleuthing

in rescue mode of vsidl who -r  yields no response other attempts in rescue mode

systemd -cgls
failed to create bus connection

BUT 
ps xawf -eo pid,user,group,cgroup,args

yields quite a bit of data when run as root inside a terminal in the gui.  I came upon this via a Nov 6, Carla Schroder article.  I have read parts at least of her books in the past.

from syslog I noticed that  ntp was  slow  so

systemctl restart ntp
failed to get Dbus connection unknown error #1

systenctl daemon reload
failed to get Dbus connection

I  might go back to the dpkg log and re-search all instances of remove. 

It just might be a good idea to wipe and re-install.  Just might be a learning experience I needed to never use apt-get autoremove in sid. 


7
VSIDO Installation Help / init 's scrambled
« on: November 25, 2014, 01:01:15 AM »
Hi,   inits are scrambled.

installed maybe 2 days ago, no problems.  But, tried the live-version of another sid  for the LXQT, but ... 

EDIT 4 days later.  Never solved, but the wicd/ceni hiccup was probably part of.  still not sure how libpam-systemd got removed.  AND - I did not have a clean home.  I had backed up home and was going to format sda2 which is home for for both sid distros I tried, but it did not happen.  In the end I did overkill, formatted sda2 to reiser and then back to ext4.  I have a working sid now, but with lxqt in another brand. 

Vsido did install perfectly my first time     End of EDIT

Reinstalled VSIDO last night- went well.  I went to terminal after Ctl-Alt-F1 and init 3.  I did all my apt-getting after installing apt-listbugs and echo "pkg" hold of libpython2.7-stdlib and systemd.  I added fdupes, ncdu and a couple of other cli's.  I unplugged ehternet, but did not set up wicd for wlan0.  When I went back to add opera,  etc., etc. I realized this.  I had to kill (not kill-9) wicd   I did this via rm wicd.pid  I set up wlan0 with ceni. 

However, from then on,  any way I go after it, my inits are off.  If I go Ctl-Alt-F1 I see the mesages (I copied from screen - typos)  lightdm -14.264861 system log failed to enable subscription   and Failed to fully start up daemon.  Then 5 or more repeats of authentication failed.  Ctl-Alt-Del puts me back into a restart that ends with a fully functional VSIDO gui. 

Booting into rescue mode can get me into a fully funcional gui.  I go into root, type init 3 and it restarts to lightdm log in and fully functional gui.

Trimmed lightdm log

Code: [Select]
[+0.20s] DEBUG: Could not run plymouth --ping: Failed to execute child process "plymouth" (No such file or directory)

+0.20s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.20s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.21s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
[+0.21s] DEBUG: Loading user config from /etc/lightdm/users.conf
[+0.22s] DEBUG: User   ** added

+7.95s] DEBUG: Session pid=2276: Greeter sets language en_US.utf8
[+7.96s] DEBUG: Session pid=2276: Greeter requests session fluxbox
[+7.96s] DEBUG: Seat: Stopping greeter; display server will be re-used for user session
[+7.96s] DEBUG: Session pid=2276: Sending SIGTERM
[+8.01s] DEBUG: Session pid=2276: Greeter closed communication channel
[+8.01s] DEBUG: Session pid=2276: Exited with return value 0
[+8.01s] DEBUG: Seat: Session stopped
[+8.01s] DEBUG: Seat: Greeter stopped, running session
[+8.01s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
[+8.02s] DEBUG: Session pid=2392: Running command /etc/X11/Xsession /usr/bin/startfluxbox
[+8.02s] DEBUG: Creating shared data directory /var/lib/lightdm/data/paxmark
[+8.02s] DEBUG: Session pid=2392: Logging to .xsession-errors
[+8.11s] DEBUG: Activating VT 7
[+8.11s] DEBUG: Activating ConsoleKit session 6953a01422b43ca01a15fdee52a3cc7c-1416868272.704141-2006332528
[+8.12s] WARNING: Error activating ConsoleKit session: GDBus.Error:org.freedesktop.DBus.GLib.UnmappedError.CkVtMonitorError.Code0: Session is already active



attempts at journald
Code: [Select]
**@**:~$ journalctl -b
No journal files were found.
paxmark@rauneseee:~$ sudo journalctl -b
[sudo] password for **:
No journal files were found.
**@**:~$ sudo journalctl -f
No journal files were found.

After about the fourth time of attempting Ctl-Alt-F1 I undid the hold of systemd and did the apt-get distupgrade.   I got no new problems and  still have the above problem. 

Been looking at logs, googling, and I am stumped.  Could be systemd libpam or lightdm.    Stumped.  Peace.

edited 10pm  Lot of looking.  One thing it looks like I did wrong was after removing gmusicbrowser and vlc (going with mpv) I did an apt-get autoremove.  NO NO in sid I guess.  Damage was libpam-systemd  Reinstalled tonight  and I was able to get output from systemd --test  as opposed to $HOME  blahblah.  Still run inits a jumble and authentication failures.  GUI works fine. 

Pages: [1]