VSIDO Community

VSIDO Support => General Support => Topic started by: Digit on February 06, 2013, 11:28:22 AM

Title: [SOLVED] synaptic fails to launch, cannot find display
Post by: Digit on February 06, 2013, 11:28:22 AM
[edit] the short story:  had made typo on install, and had an "ah" instead of a "ha" in my computers name.  had renamed it in host file, but xauth still needed to be told.  so i told it, n now it's fixed.  fin.[/edit]

Code: [Select]
(synaptic:5597): Gtk-WARNING **: cannot open display: :0
^is the error i get any time i attempt to launch synaptic in a terminal, whether as root, using sudo, or gksu.

tried telling it to use displays 1-3 too, same result, different number.

in desperation i even tried un-installing and re-installing it.

running it from gmrun, with gksu, it takes me to the message box informing me it will launch without asking for root perms, but when i close that, instead of seeing synaptic, i get nothing.  same result with launching it from the desktop menu's "root" menu.

htop shows it is not running.

same story with gparted.

what have i done?  :O
fairly sure i had run gparted at some point earlier...  or maybe that was just in the live system.

this is on the debian sid version of vsido... release before last, i think.
Linux levinrhan 3.7-trunk-amd64 #1 SMP Debian 3.7.1-1~experimental.2 x86_64 GNU/Linux
^ that one.  er... tho, that's after an upgrade or two... meh, should still be same kernel, i dont recall rebooting or switching to new kernel.

really would prefer not giving up on vsido... but inability to run synaptic, is a deal breaker.   getting the info i need from apt get/cache is just too clumsy in some cases.

ps, tips from here [ http://crunchbang.org/forums/viewtopic.php?id=23975 (http://crunchbang.org/forums/viewtopic.php?id=23975) ] failed to remedy the problem for me.
Title: Re: synaptic fails to launch, cannot find display
Post by: Digit on February 06, 2013, 01:05:32 PM
also, just noticed... i have been able to run things as root in x before... i have spacefm open still.  but can no longer start another instance of spacefm as root.  definately done something bad...

~(ah, found the modify button.  was looking along the bottom of a post for an edit button before.)~

Code: [Select]
export DISPLAY=:0.0also failed to remedy

a few other things tried n failed...
but now, seems like i have a clue to work from:
Code: [Select]
xauth list $DISPLAY returns nothing.  it should return something like
Code: [Select]
somehost.somedomain:10 mit-magic-cookie-1 4d22408a71a55b41ccd1657d377923ae according to that thread on lq

last post suggested
Code: [Select]
xauth $DISPLAYwhich just gave
Code: [Select]
xauth: (argv):1:  unknown command ":0.0" which gave me the idea of trying just
Code: [Select]
xauth listwithout the trailing "$DISPLAY" as first suggested, and there i got something that looked more like useful output:
Code: [Select]
levinrahn/unix:0  MIT-MAGIC-COOKIE-1  b14aff4blah7537ablah74dcblahd0be which i am now about to attempt to feed in, into the correct place, after having written all this to keep the progress report in this thread up to date...


upon closer reading of that post suggesting "xauth list $DISPLAY" i think maybe they didnt mean to add the $DISPLAY, from how they word it in the brackets which i must have skimmed past too carelessly on first read.

that "levinrahn/unix" concerns me for a couple reasons, before i hit enter on
Code: [Select]
xauth add levinrahn/unix:0  MIT-MAGIC-COOKIE-1  b14aff4blah7537ablah74dcblahd0bethat's not my host anymore.

it was a typo on installation that i thought i'd fixed post instalation.  levinrahn -> levinrhan.  seems this may be the source of my woes.

so i change it to
Code: [Select]
xauth add [b]levinrhan[/b]/unix:0  MIT-MAGIC-COOKIE-1  b14aff4blah7537ablah74dcblahd0beand pray that it saying unix like that there ((weird)), is a non-issue...


...hits enter...

...no errors in terminal...

...jumps to the menu to attempt to launch something as root...

...sees synaptic show up...

...smiles, and goes off to mark this shit solved, and congratulates himself for learning something through troubleshooting.

isnt gnu adorable like that?  :)
Title: Re: [SOLVED] synaptic fails to launch, cannot find display
Post by: VastOne on February 06, 2013, 03:00:56 PM
So you solved it digimon?

I am not seeing these issues nor can I reproduce them
Title: Re: [SOLVED] synaptic fails to launch, cannot find display
Post by: Digit on February 06, 2013, 03:28:35 PM
yeah, was an issue totally of my own creation.

added a short-version of the situation to the start of the op.  all started from changing the host name.  all is well now.  :)

ps, please dont call me that. XD  *cringe*