VSIDO Community

VSIDO Support => General Support => Topic started by: falldown on January 31, 2013, 07:32:06 PM

Title: SID package warning..
Post by: falldown on January 31, 2013, 07:32:06 PM
Well out of embarrassment I posted here..
I just did a
Code: [Select]
sudo apt-get dist-upgrade
Everything went fine except for a ??"libpango"?? package.
It ask me if I wanted to keep installed package or maintainers package.
Not knowing what to do I did maintainers package.

after reboot.. x will not start.
I drop into tty and
Code: [Select]
sudo startxI get
Code: [Select]
/ect/x11/xini/xserver: 3: exec: /user/bin/x: not found
xiniti: unable to connect to xserver: connection refused

So how do I find what I installed and how to fix it?
Title: Re: SID package warning..
Post by: VastOne on January 31, 2013, 07:50:04 PM
Did you use smxi to install nVidia drivers?  I would just use smxi again to install the nVidia drivers or whatever method you used to install them...

I am not too sure if the issue is related to libpango

I just did a total dist-upgrade and never saw this... is libpango part of a package you installed?

FWIW, I always keep my version and do not let the maintainers package update it, or I look at the differences and decide from there
Title: Re: SID package warning..
Post by: falldown on January 31, 2013, 08:15:03 PM
It is my testing partition VastOne.
All default settings and drivers.
If anything I will reinstall.
I was just wanting to warn others about a possible "unstable" package.

I was busy with other things during the upgrade (big no-no)

side note.. what happened to the cool smileys??


Title: Re: SID package warning..
Post by: Sector11 on January 31, 2013, 08:21:31 PM
Interesting, I just did an update/dist-upgrade because of this thread (I needed to anyway) and saw nothing like this.

It's not NVIDIA related - it's associated with pango (http://www.pango.org/) - text rendering.

cool smilies are back - nice.  ;D
Title: Re: SID package warning..
Post by: VastOne on January 31, 2013, 08:24:18 PM
Interesting ... I have libpango-perl installed and I believe it is part of GMB. It was updated along with all of Perl a couple of days ago and today on a new install but I did not see the maintainer message.

The smilieys should be fixed... I inadvertently changed them and did not realize it... my bad!
Title: Re: SID package warning..
Post by: jedi on January 31, 2013, 08:45:09 PM
I also have libpango-perl installed.  I thought it was part of a text rendering thing for Internationalization though....

I also after reading these posts did an apt-get update/apt-get dist-upgrade with no issues.  Also noticed the update to Grub 2.00-12...

Everything working fine, no issues here at all.