Author Topic: enable tapping  (Read 1138 times)

0day

  • Posts: 44
    • View Profile
enable tapping
« on: January 08, 2014, 01:10:49 PM »
tapping don't work on notebook and link of menu touchpad/mouse don't work.

jedi

  • DEFCON 1
  • Posts: 1593
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: enable tapping
« Reply #1 on: January 08, 2014, 01:44:48 PM »
hey 0day!  Here is a little super simple script I wrote and put in my startup to give me tap features as well as making the touchpad disabled when kbd is being used.  (disables the touchpad for 2 seconds)  I simply name it tap.sh and place it in the /home/yourusername/ folder.  I use Fluxbox, so in the .fluxbox folder in the "startup" file just add "~/tap.sh" without the quotes, somewhere before the end of the file.

Code: [Select]
#!/bin/sh

synclient TapButton1=1
synclient TapButton2=3
syndaemon -i 2 -d
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

0day

  • Posts: 44
    • View Profile
Re: enable tapping
« Reply #2 on: January 08, 2014, 02:13:57 PM »
ok, thanks but menu>touchpad mouse don't work?

jedi

  • DEFCON 1
  • Posts: 1593
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: enable tapping
« Reply #3 on: January 08, 2014, 09:55:42 PM »
Never did for me, that's why I wrote the script...

Make sure you change the permissions and set it to executable as well.  Forgot to mention that in the first post.   :)
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

0day

  • Posts: 44
    • View Profile
Re: enable tapping
« Reply #4 on: January 08, 2014, 11:24:00 PM »
solved with:

#!/bin/sh
#
# fluxbox startup-script:
#
# Lines starting with a '#' are ignored.

# Change your keymap:
xmodmap "~/.Xmodmap"

# Applications you want to run with fluxbox.
# MAKE SURE THAT APPS THAT KEEP RUNNING HAVE AN ''&'' AT THE END.
#
# unclutter -idle 2 &
# wmnd &
# wmsmixer -w &
# idesk &
#
# Debian-local change:
#   - fbautostart has been added with a quick hack to check to see if it
#     exists. If it does, we'll start it up by default.
which fbautostart > /dev/null
if [ $? -eq 0 ]; then
    fbautostart
fi

# enable tapping:
synclient VertEdgeScroll=1
synclient HorizEdgeScroll=1
synclient TapButton1=1

# And last but not least we start fluxbox.
# Because it is the last app you have to run it with ''exec'' before it.

# exec fluxbox

fluxbox &
fbpid=$!

sleep 1
{
compton --config ~/.compton.conf &
(sleep 3s && wicd-gtk --tray) &
(sleep 3s && conky -c ~/.conkyrc) &
nitrogen --restore &
(sleep 3s && lxpanel) &
## tint2 -c /usr/local/bin/.tint2oblaunchers/tint2rc &
## (sleep 3s && tint2 -c /usr/local/bin/.tint2oblaunchers/tint2rcallbtm) &
## vsido-welcome - post-installation script, will not run in a live session and
## only runs once. Safe to remove.
(sleep 6s && vsido-welcome --firstrun) &
   # MAKE SURE THAT APPS THAT KEEP RUNNING HAVE AN & AT THE END.
   # ipager &
   # gkrellm2 &
} &

wait $fbpid

# or if you want to keep a log:
# exec fluxbox -log "~/.fluxbox/log"