Author Topic: [SOLVED] Cups service doesn't autostart  (Read 2208 times)

orcrist

  • Posts: 15
    • View Profile
[SOLVED] Cups service doesn't autostart
« on: November 03, 2013, 06:21:08 PM »
I would like to have the cups service start at boot but I cannot figure out how. I have had the packages installed by the vsido-welcome script and I can start the service manually (sudo /etc/init.d/cups start).
Having it enabled by boot-up-manager seems to change nothing.
Thanks in advance.

 

VastOne

  •      v-ger
  • Posts: 3861
    • View Profile
    • VSIDO Community
Re: Cups service doesn't autostart
« Reply #1 on: November 03, 2013, 11:45:52 PM »
Check your /etc/network/interfaces and make sure this is in it

Code: [Select]
auto lo
iface lo inet loopback

Then restart and see if that resolves it

This is a strange one... but a bug no less... Let me know if it does solve it
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

statmonkey

  • Posts: 330
    • View Profile
Re: Cups service doesn't autostart
« Reply #2 on: November 04, 2013, 02:43:42 AM »
Just ran into this myself. A couple of ways to handle it.

sysv-rc and set it with a tick mark for the levels you want
or
sudo update-rc.d cups enable

if you are using systemd then use
systemctl command

lwfitz

  • DEFCON 1
  • Posts: 1734
  • sudo rm -rf /
    • View Profile
Re: Cups service doesn't autostart
« Reply #3 on: November 04, 2013, 04:37:38 AM »
Funny, I almost never print anymore but I ran into this the other day on my office machine and thought I was going crazy.

Ill test that out tomorrow statmonkey.

orcrist

  • Posts: 15
    • View Profile
Re: Cups service doesn't autostart
« Reply #4 on: November 04, 2013, 05:43:08 PM »
Check your /etc/network/interfaces and make sure this is in it

auto lo
iface lo inet loopback

Then restart and see if that resolves it

This is a strange one... but a bug no less... Let me know if it does solve it

My /etc/network/interfaces is exactly like this. No, the problem is still there.

orcrist

  • Posts: 15
    • View Profile
Re: Cups service doesn't autostart
« Reply #5 on: November 04, 2013, 05:53:28 PM »
Just ran into this myself. A couple of ways to handle it.

sysv-rc and set it with a tick mark for the levels you want
or
sudo update-rc.d cups enable

if you are using systemd then use
systemctl command

Thanks! "sudo update-rc.d cups enable" did the trick.

statmonkey

  • Posts: 330
    • View Profile
Re: [SOLVED] Cups service doesn't autostart
« Reply #6 on: November 04, 2013, 07:33:05 PM »
Glad it worked and you got it solved.