Author Topic: HDMI Audio <SOLVED>  (Read 3182 times)

lwfitz

  • DEFCON 1
  • Posts: 1758
  • sudo rm -rf /
    • View Profile
HDMI Audio <SOLVED>
« on: July 18, 2013, 01:21:03 AM »
No matter what I do I am unable to get audio working via HDMI

lspci -v | grep Audio (onboard audio disabled)
Code: [Select]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Juniper HDMI Audio [Radeon HD 5700 Series]

aplay -l
Code: [Select]
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Any ideas?




VastOne

  •      v-ger
  • Posts: 3964
    • View Profile
    • VSIDO Community
Re: HDMI Audio
« Reply #1 on: July 18, 2013, 01:32:46 AM »
Open alsamixer in terminal and make sure your card is selected

Use the arrow key over to S/PDIF and make sure it says 00 and not MM. Use the m key to change it.  If there are two S/PDIF settings do the same with both

VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

lwfitz

  • DEFCON 1
  • Posts: 1758
  • sudo rm -rf /
    • View Profile
Re: HDMI Audio
« Reply #2 on: July 18, 2013, 01:38:52 AM »
Already done and I have the onboard audio disabled through the bios so the only audio source is HDMI

VastOne

  •      v-ger
  • Posts: 3964
    • View Profile
    • VSIDO Community
Re: HDMI Audio
« Reply #3 on: July 18, 2013, 01:44:50 AM »
Strange... alsa is seeing it fine then.  Are you trying it in GMB?  I also have pulse installed but that does not make a difference
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

lwfitz

  • DEFCON 1
  • Posts: 1758
  • sudo rm -rf /
    • View Profile
Re: HDMI Audio
« Reply #4 on: July 18, 2013, 01:56:39 AM »
No, I was actually trying to play something in a browser. But I have tried with pithos and now with gmb and get the same result. No audio  >:(

VastOne

  •      v-ger
  • Posts: 3964
    • View Profile
    • VSIDO Community
Re: HDMI Audio
« Reply #5 on: July 18, 2013, 02:13:13 AM »
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

lwfitz

  • DEFCON 1
  • Posts: 1758
  • sudo rm -rf /
    • View Profile
Re: HDMI Audio
« Reply #6 on: July 18, 2013, 02:19:14 AM »
Seems very similar except that in that case there is some audio and I have none at all.

Im using the preinstalled drivers, maybe thats the issue? Problem is I dont think catalyst will install on the 3.9 kernel. I might just have to use the onboard audio with external speakers.


Heading home and will see if I can get this figured out on my home PC too

jedi

  • DEFCON 1
  • Posts: 1556
  • Not all those who wander are lost.
    • View Profile
    • NixNut.com
Re: HDMI Audio
« Reply #7 on: July 18, 2013, 05:22:27 AM »
hey lwfitz.  I think I remember something about this in the past.  I also think it came down to being something to do with Catalyst.  Wish I could be more helpful.  Also, I may be talking out of the other side of my mouth!  It may have just been a bad dream.  (I personally have never utilized the HDMI hardware on my lappy since starting all this excitement!)  I've also been under the impression that the HDMI audio is controlled via the video card and only works if plugged in via an HDMI cable.  However, I'm not sure of that either.

So in other words, just forget I made this post!!!
Forum Netiquette

"No matter how smart you are you can never convince someone stupid that they are stupid."  Anonymous

lwfitz

  • DEFCON 1
  • Posts: 1758
  • sudo rm -rf /
    • View Profile
Re: HDMI Audio
« Reply #8 on: July 18, 2013, 09:14:35 AM »
 :D :D Jedi!

I believe your right on about most of that actually  ??? ???

I think I need to get catalyst. That will be my goal for tomorrow!

lwfitz

  • DEFCON 1
  • Posts: 1758
  • sudo rm -rf /
    • View Profile
Re: HDMI Audio
« Reply #9 on: July 18, 2013, 09:06:23 PM »
Ok I got everything working by installing Debian's AMD/ATI driver packages via apt

Code: [Select]
sudo apt-get install dkms linux-headers-$(uname -r) fglrx-driver fglrx-control xvba-va-driver
Code: [Select]
sudo aticonfig --initial
reboot and run

Code: [Select]
gksudo amdcccle
to configure displays.

HDMI audio works perfect now

VastOne

  •      v-ger
  • Posts: 3964
    • View Profile
    • VSIDO Community
Re: HDMI Audio <SOLVED>
« Reply #10 on: July 19, 2013, 08:59:53 PM »
^ Nicely done Sir!
VSIDO      VSIDO Twitter     VSIDO FB     VSIDO Google+   

I dev VSIDO

sqlpython

  • Posts: 70
    • View Profile
Re: HDMI Audio <SOLVED>
« Reply #11 on: July 20, 2013, 03:17:27 AM »
@lwfitz
Good one! That is staying on the horse.
 Never encountered the same but I made a How To of your solution.
 Just in the event.....
Stretch, Siduction-15.1,  Slackware 14.1, LMDE, Calculate 15.7

lwfitz

  • DEFCON 1
  • Posts: 1758
  • sudo rm -rf /
    • View Profile
Re: HDMI Audio <SOLVED>
« Reply #12 on: July 20, 2013, 05:07:49 AM »
@ VastOne and sqlpython

Thanks guys. I normally wouldnt install fglrx via apt but since smxi doesnt support instillation while using the 3.9 kernel this was my only way.
I guess compiling the driver would be another option and Im lazy lately so that wasnt gonna happen  ;D